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User Guide

Freatures

e Module LoRa SAMR34 V4.1 (Based on ATSAMR34J18B LoRa IC)
- Cortex® MO+ CPU and LoRa Transceiver
- Frequency Range: 862 to 928 MHz
- 2-Kbit Serial EEPROM + Factory-Programmed EUI-48™ Address
- On-Board 32MHz TXCO
- U.FL RF connectors (MHF)

o [solated RS-485 Interface

e Serial USB and Target USB Connector with ESD Protection

e 3 GPIO LEDs

e Manual Reset Button

e GPIO Button

e Board Supply (USB bus, external VIN 12VDC)
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1

Overview

1.1 Evaluation Board

LoRa SAMR34 EVA MODBUS V1.0 Board’s overview

Extension Header P1 LoRa_SAMR34A_Vd4.1 Module

Supply & R5485 Connector —p
VIN 12vVDC)

itch 5.0mm

RS485 Dip Switch —— &

RF Connector LED1 GPIO LED2 GPIO

MHE

Extension Header P2

1.2 Development environment and Tool

e Microchip Studio
https://www.microchip.com/en-us/development-tools-tools-and-software/microchip-studio-for-avr-
and-sam-devices

e ATMEL ICE
https://ww1.microchip.com/downloads/en/DeviceDoc/Atmel-ICE_UserGuide.pdf

e Terminal emulator software: Tera Term

https://ttssh2.o0sdn.jp/


https://www.microchip.com/en-us/development-tools-tools-and-software/microchip-studio-for-avr-and-sam-devices
https://www.microchip.com/en-us/development-tools-tools-and-software/microchip-studio-for-avr-and-sam-devices
https://ww1.microchip.com/downloads/en/DeviceDoc/Atmel-ICE_UserGuide.pdf
https://ttssh2.osdn.jp/
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2 Hardware User Guide

2.1 Power Supply Diagram

The LoRa_SAMR34 EVA MODBUS board can be powered by External 12V or Serial USB 5V

Converter 3.3VUSB_ USB to
3.3V g UART
Converter
Serial USB 5VUSB .| Converter
5V " 3.3V
External 12V Converter | 5VDC Converter ¥ 3.3VCC SAMR34
: > ——> ———»
input 5V 3.3V module
»| Peripherals
L P
Isolated +5V RS485
»| Converter >
module
5V

2.2 Board Connectors
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Note : For more details on Pin descriptions, refer to SAM R34/R35 Low Power LoRa Sub-GHz SiP Datasheet (Table 5-1. Port
Function Multiplexing)


https://ww1.microchip.com/downloads/aemDocuments/documents/OTH/ProductDocuments/DataSheets/SAM-R34-R35-Low-Power-LoRa-Sub-GHz-SiP-Data-Sheet-DS70005356C.pdf

# Electronics
Source LoRa_SAMR34_EVA_MODBUS User Guide

2.2.1 Extension Header P1

Extension Header P1
ET. Erey— Pins on LoRA SAMR34 Module Shared Functionality
1,2 PA06 PAO6 -
3,4 PAO7 PAO7 -
5,6 PA08 PAO8 UART TX
7,8 PAO9 PAO9 UART _RX
9, 10 pB22 PB22 -
11,12 PAl6 PAl6 EDBG_|2C SDAM
13, 14 PAL7 PA17 EDBG_I2C scL™
15, 16 PAL8 PA18 EXT2, USB_VBUS®!
17, 18 PA19 PA19 EXT3, SWO
19, 20 RST RESET* RESET*
21,22 PA30 SWCLK SWCLK
23,24 PA31 SWDIO SWDIO
25, 26 PA14 PA14 TXCO_PWRM
27, 28 GND GND -
[ On board LoRa_SAMR34A V4 module - refer LoRa_SAMR34A V4 DataSheet(Schematic)
B3I Optional
2.2.2 Extension Header P2
Extension Header P2
. — Pins on LoRA_SAMR34 Module Shared Functionality
1,2 PB03 PBO3 -
3,4 PAO4 PAO4 UART TX?
5,6 PAO5 PAO5 UART RX¥
7,8 PB02 PB02 -
9,10 PA28 PA28 -
11,12 PB23 PB23 -
13, 14 PA24 PA24 UsB DM
15, 16 PA25 PA25 USB DP
17,18 PA23 PA23 LEDO
19, 20 PA22 PA22 LED1
21,22 PA15 PA15 LED2
23,24 PA27 PA27 -
25,26 GND GND -
27,28 3V3 - 3.3V Supply to peripherals
29, 30 5V - 5V Supply to peripherals

ZIRS485 UART pin - change this pin to General purpose /0 pin by remove R38, R39 on LoRa_SAMR34 EVA MODBUS board


https://www.dropbox.com/s/yyztmlwajxn98k6/Module_LoRa_SAMR34A_V4_DataSheet.pdf?dl=0
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2.2.3 Programming Connector CN1

Pin No. Pin Name Description
1 GND GND
2 RST RESET*
3 SWCLK SWCLK
4 SWDIO SWDIO

2.2.4 Supply and RS485 Connector CN3

Pin No. Pin Name Description
1 GND GND
2 12v Supply Input 12VDC
3 A RS485 A
4 B RS485 B

2.3 Peripherals

2.3.1 LED Connections

Pin Name Function Shared Functionality
PA23 Yellow LEDO p2
PA22 Green LED1 p2
PA15 Red LED2 p2

2.3.2 Mechanical Buttons

Pin Name Function Shared Functionality
RESET* RESET P1, Programing connection
PA28 SWO0 P2

2.3.3 Serial USB

Pin Name Function Shared Functionality
PAQS™ S1_UART TX P1
PAQ9™ S1_UART RX P1

[ change this pin to General purpose I/0 pin by remove R36(PAQ9), R37(PA08) on Evaluation board

2.3.4 Target USB

Pin Name Function Shared Functionality
PA25 USB DP P2
PA24 USB DM P2
PA18E! VBUS EXI (Optional) | P2

Bl change this pin to General purpose I/0 pin by remove R25 on Evaluation board

2.3.5 UART RS485

Pin Name Function Shared Functionality
PAQ4LE! SO_UART TX P2, RS485 Connection
PAQ5® SO_UART RX P2, RS485 Connection

6l change this pin to General purpose /O pin by remove R38(PA05), R39(PA04) on Evaluation board
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3 Example Demo Project

This Application is used to send count payload number and example data payload through the LoRaWAN
Network.

e Establish a LoRaWAN connection automatically between the SAMR34 end node and available Gateways
that are within radio range.

e The UART is used to display the menu options, The user input is provided through keyboard.

e Periodically transmit a confirmed data frame (default periodic timer duration 10 seconds).
Define by DEMO_CONF_APP_PERIODIC_TIMER_PERIOD_MS in conf_app.h.

e Use pushbuttons SW0 on the board for wake up from sleep mode and show app information via a USB
Interface.

e LED1 shows LoRaWAN operating status.

3.1 Setup

1. Download source code LORAWAN P6 MODBUS DEMO, Open Microchip Studio and Select File >
Open > Project/solution... . Select .\LORAWAN_P6_MODBUS_DEMO_V1.atsln and open.
2. The connection shown in figure.
- Evaluation Board
- ATMEL-ICE
- Antenna
- Micro USB cable (for Serial USB)
- Micro USB cable (for Target USB) (Optional)

Note : For connector pin and details, see 1.1 Evaluation Board and 2.2 Board Connectors


https://www.dropbox.com/sh/jp0om4mm8nlz2u5/AABV9DaMPsEbGVidFUIid6Ala?dl=0
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3. Open Terminal emulator software, Setting UART interface are as follows.
- UART : 9600 bps 8N1
- USB: 115200 bps 8N1

Note : for Tera Term, Setup > Terminal... set New Line Transmit as CR+LF.

Tera Terrm: Terminal setup X
Terminal size New-line
| | X |56 | Receive: CR  ~
Term size = win size Transmit: | CR+LF ~ Cancel
Auto window resize
Help
Terminal ID: WT100 -~ M Local echo
Answerback:l:| [ Auto switch (VT<-=TEK)
Coding (receive) Coding (trapnsmit)
UTF-8 ~ UTF-8 ~
locale: | american
3.2 Application Configuration
3.2.1 Define application configuration parameters in ..\src\config\conf_app.h
Solution Explorer >3 x
@ o-aB |- [
p-
i Solution 'APPS_ENDDEVICE' (1 project) &
4 | APPS_ENDDEVICE
4 Dependencies
P Output Files
=4 Libraries
4 L src
b (@3 ASF
“ onfi
S
1} conf_board.h
1} conf_clocksh
1} conf_extinth
1} conf_hw_timer.h
) conf_nvmh
) conf_pmmh
1} conf_regparamsh
1} conf_resource.n
1} conf_rtch
1} conf_sio2hosth
1} conf_spih
conf_sw_timerh -
Solution Explorer
3.2.2 Activation Method and Type of Transmission
/* Activation method constants */
#define OVER_THE_AIR_ACTIVATION LORAKAN_OTAA
#define ACTIVATION_BY_PERSONALIZATION LORAWAN_ABP
/* Message Type constants */
sdefine UNCONFIRMED LORA!\AH_UNCMF
#define CONFIRMED LORARAN_CNF Activation Method
#define DEMO_APP_ACTIVATION_TYPE OVER_THE_AIR_ACTIVATION
//#define DEMO_APP_ACTIVATION_TYPE ACTIVATION_BY_PERSONALIZATION

/* Select the Type of Transmission Confirmed(CNF) / Unconfirmed (UNCNF)
//8define DEMO_APP_TRANSMISSION_TYPE UNCONF IRMED
#define DEMO_APP_TRANSMISSION TYPE CONFIRMED

Type of Transmission
3.2.3 Device Class

/* Device Class - Class of the device (CLASS_A/CLASS C) */
#define DEMO_APP_ENDDEVICE_CLASS CLASS_A
//#define DEMO_APP_ENDDEVICE_CLASS CLASS _C
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3.2.4 Join Parameter

This application can set DevEUI or read form EUI-48 MAC Address. (see in 5.1 EUI Address)

J/* ABP loin Parameters */

#define DEMO_DEVICE_ADDRESS Bxabcd@@al

#define DEMO_APPLICATION_SESSION_KEY {ex10, Ox00, 0x28, Ox00, Ox30, Ox00, Ox40, 0x00, Ox50, 0x00, Ox60, 0x00, @x70, 0x00, Ox80, Ox0A}
#define DEMO_NETWORK_SESSION_KEY {ex10, ox00, 0x28, Ox00, Ox30, Ox00, Ox40, 0x00, Ox50, 0x00, Ox60, 0x00, @x70, 0x00, Ox80, Ox0A}
/* OTAA Join Parameters */

#define DEMO_DEVICE_EUI {exe@, 0x01, 0x00, 0x08, Ox35, Ox8f, 0x00, 0x00}

#define DEMO_APPLICATION_EUI {0x00, 0x00, 0x00, 0x00, 0x00, Ox00, 0x8d, 0x085}

#define DEMO_APPLICATION_KEY {ox00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, Ox00, Ox00, ©x00, 0x00, 0x00, 0x00, 0x05}

3.2.5Region Profile

/* ISM Band Types */

| #define DEMO_APP_ENDDEVICE_BAND
// #define \l NI

ISM_THAI923 /*Thailand*/

-~ 8/0MHz ISM Band */

_APP_| ¥ TSM_EUB63 7= EU 863
// #define DEMO_APP_ENDDEVICE_BAND ISM_EU433 /* EU 433MHz ISM Band */
// #define DEMO_APP_ENDDEVICE_BAND ISM_NA915 /*AU*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_AU915 /*NA*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_KR920 /*KR*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_JIPN923 /*Japan*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_BRN923, /*Brunei*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_CMB923 /*Cambodia*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_INS923 /*Indonesia*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_LADOS923 /*Laos*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_NZ923 /*New Zealand*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_SP923 /*Singapore*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_TWN923 /*Taiwan*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_THAI923 /*Thailand*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_VTM923 /*Vietnam*/
// #define DEMO_APP_ENDDEVICE_BAND ISM_IND865 /*India*/
3.3 Building/Flashing the Firmware
1. Go to Build > Build Solution
[EJ Apes_ENDDEVICE - Microchip Studio
File Edit View VAssistX ASF Project | Build | Debug Tools Window Help
©-0|B-a -2 M| |/ suidSoluton 3] De|L<_
MBe|>np|latarn] Rebuild Solution Ctri+AltsF7 188
W Clean Solution
sl & Build APPS_ENDDEVICE
Configuration: |Active (Det  Rebuild APPS_ENDDEVICE
Build Events

Device

[ 4 [ ARM/GNU Common)

Clean APPS_ENDDEVICE
Batch Build...
Configuration Manager..

2. After Output pane shown Build succeeded, go to Tool > Device Programming

Outy

put

Show output from:  Build

e lwuE

UDone executing task "KunUutputhileVeritylask™.

Done building target "CoreBuild"” in project "LORAWAN_P6_MODBUS_DEMO_V1.cproj”.

Target “"PostBuildEvent™ skipped, due to false condition; ('$(PostBuildEvent)' !=
Target "Build" in file "C:\Program Files (x86)\Atmel\Studio\7.8\Vs\Avr.common.targets" from
Done building target "Build” in project "LORAWAN_P6_MODBUS_DEMO_V1.cproj”.
Done building project "LORAWAN_P6_MODBUS_DEMO_V1.cproj”.

Build succeeded.
------- == Build: 1 succeeded or up-to-date, @ failed, @ skipped ===s=swwus

4

Error List Koy

') was ev

APPS_ENDDEVICE - Microchip Studio

Edit View VAssistX ASF Project Buld Debug | Tools  Window Help
o |B-@0-Lad X |9 - & - B command Prompt
Gowl>mp|et @t v | Hex | @ & Device Pack Manager

iid
ild Events

APPS_ENDDEVICE + X

Configuration: | Active (Debug)

Configuration Manager...

wice
ol
ks

vanced

4 [ ARM/GNU Commen ~
A General
& Output Files
4 [ ARM/GNU C Compiler
A General
= Preprocessor
[ symbols
 Directories
= Optimization
[ Debugging
& Warnings
[ Miscellaneous

i
E
4

E

E

Device Programming
rogramming Center
Add target..

Data Visualizer
Select profile

4[] Code Snippets Manager...
Extensions and Updates..

External Tools...

Customize...

1 ¥ options..

Import and Export Settings.

Ctrl+Shift+P

Ctrl+K, Ctri+B

USART_CALLBACK_MODE=true
EDBG_EULREAD=1
DEMO_APP_ENABLE=1
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3. From the Tool list, setect Atmel-ICE

Device Programming ? X
Tool Device Interface Device signature Target Voltage
¢ Atmel-ICE V}I ATSAMR34/18B  ~ I SWD v |Apply not read Read - Read @

~

4. Select Device ATSAMR34J18B, click Read at Device signature

Atmel-ICE {J41800095654) - Device Programming ? x

Tool Device Interface Device signature Target Voltage

Atmel-ICE ~ | ATSAMR34/188 ~ |SWD ~|[Apply] ow10810228 33V |[Read| 53]

Interface settings SWD Clock \

Tool information 2 MHz

Device information
Memaries The clock frequency should not exceed target CPU speed * 10.
Fuses Set

Security

5. Click Memories, In the Flash pane, Browes for the .\Debug\LORAWAN P6 MODBUS DEMO V1.elf
or .\Debug\LORAWAN _P6 MODBUS DEMO_V1.hex, then click Program

Atmel-ICE (}41800095654) - Device Programming ? » |
Tool Device Interface Device signature Target Voltage
Atmel-ICE ~ | ATSAMR34/188  ~ |SWD ~ | [Apply] o0x10810228 Read| = 33V [Read] [{3

Device

Interface settings

Tool information Erase Chip ~ | Erase now

Device information Flash (264 KB)
: | | DALWork\LWork\2021\5.LoRa_SAMR34_EVA_MODBUS(ES)\Code\LORAWAN_P6_MODBUS_DEN E[l

[f] Erase Flash before programming

[ Verify Flash after programming Eiugram ‘ ey | | e
Advanced
Atmel-ICE (J41800095654) - Device Programming ? X |
Tool Device Interface Device signature Target Volitage
Atmel-ICE v | ATSAMR341188 v |swD ~|[Apply] (0x10810228  [Read| 33V |[Read| [%
Interface settings Device
Tool information Erase Chip ~ | | Erase now
Device information Flash (264 KB)
Mo ones DAL Work\1Work\2021\5.LoRa_SAMR34_EVA_MODBUS(ES)\Code\LORAWAN_P6_MODBUS DEV ~ | [
[/ Erase Flash before programming - T
Fuses
! [/] Verify Flash after programming ’ Vesily ‘ l Read...
Security @ Advanced
User Page (256 bytes)
[] Erase User Page before programming Readr
[V] Verify User Page after programming
@ Advanced
Erasing device... OK
Programming Flash..OK
Verifying Flash..OK
[=] Verifying Flash...0k
Close
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3.4

Demo Application Usage

Terminal emulator software is shown in the following figure.

Aotttk

AR

upe = COHFIRHED
HE
: 01
HALC!

10
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Option 2: Sends the example data to the network server.

Enter your choice:

i

Option 3: Start periodically transmit (default periodic timer duration 10 seconds).

Define by DEMO_CONF_APP_PERIODIC_TIMER_PERIOD_MS in conf app.h.

Enter your choice:

ariodic data...

p Hode... 3lesp Hode...
4990 Gleep done: 3

Option 6: Print app information

DeyEUT @ 0x0000fc

AppEUT = D=0000000000000005

Apptey @ 0x0000000000000000000000000000000%

btbfipp Licat ion Conf igurat Lon®
ohTypa + OTAA
1 Tupe = CONFIRHED
Hp!

11
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Option 7: Resets the board (soft Reset)

Note : How to Join to LoRaWAN Network

1. Enter 6 (or 6<CR><LF>) or push a User button for shown app information and Join Parameter via UART or USB interface

—
chip Le

nard Hane - ¢

[ode Mane - LI

#:

NewElT : Ox0000f

NlawElT ¢ D=0000f

RppEUT + DL0000000000000005 RppEUT & 0~000000000000000

Appkey = Ox00000000000000000000000000000005 + 0=00000000000000000000000000000005
* #ipplicat ion

DeuType

Act ivat ionType @ OTHA Act ivat ionTupe = OTHA

: CONFIRHED ansniszion Tupe : CONFIRHED
H!

(form UART Interface) (form USB Interface)
2. Add Join Parameter to LoRaWAN Network

(Example) : LoRa gateway: Wirmnet Station 923 (Kerlink)

>rlink

Home Fleet
Fleet
RX Data Download json fleet
TX Data
Spectrum analysis Remove fleet (Delete all motes)
OTAA Fleet
Dev EUI App EUI App Key Class C
0000fcc23d227eac 0000000000000005 100000000000000000000000000000005 C I m « e

12
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(Example) : LoRa gateway: PDTIOT-IFE02 (Kerlink)

OTAA  ABP  Manage end-devices

Add end-device

Class

Activation

LoRa RF parameters

EED— Q

Type OTAA (@) ABP

Deviceaddress™  |3D224D76

10002000300040005000600070008004

1000200030004000500060007000800A

3. Push Reset Button on Evaluation Board or Enter 1 (or 1<CR><LF>) for send the join request to network server.

4 Example Modbus Demo Project

This Application is same as 3 Example Demo Project and used to be Master for Modbus Application, send

request to Slave Device and uplink Response payload through the LoRaWAN Network.

e Periodically scan Modbus Slave Device and transmit a confirmed data frame (default periodic timer

duration 10 seconds).

Define DEMO_CONF_APP_PERIODIC_TIMER_PERIOD_MS in conf app.h.

e |ED2 and LED3 show Modbus Transmitting and Receiving status.

4.1 Setup

Same as 3.1 Setup (from 3 Example Demo Project), plug External 12VDC and Connect RS485 connector to

Modbus Slave device.

External 12VDC ==p> &
Black - GND
Red - 12Vdc

RS485 Interface ==
Blue - A
Green - B

Note : For connector pin and details, see 1.1 Evaluation Board and 2.2 Board Connectors

JHERESE

13
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4.2 Application Configuration

Define application configuration parameters in “..\src\config\conf_enddevice.h”

define CONF_MODBUS_ENABLE for enable modbus option.

MODBUS_ENABLE |

|| kdefine CONF

#if defined(CONF_MODBUS_ENABLE)
#define MODBUS_RESPONSE_TIMEQUT (580u)
#define MODBUS_REQUEST_REPEAT (2u)

4.3 Demo Application Usage

The Menu Option as shown in the following figure.
e R e e

Enter your choice:

Option 1: Sends the join request to the network server.
Option 2: Sends the example data to the network server.

Option 3: Sends the Modbus request (Request command order, see in 5.3.1 Modbus request Commands)

00aa000200030004000500060007 0003000900023
000200030004000500066F 15

20030002 0020000041

K
Option 4: Sends the Modbus request and uplink modbus response payload to the network sever. (uplink

payload, see in 5.3.2 Response Payload)

000300090004

a00020030002f 0020000641

LR R R R R R R R R R R

14
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Option 5: Start periodically transmit (default periodic timer duration 10 seconds).

Define by DEMO_CONF_APP_PERIODIC_TIMER_PERIOD_MS in conf app.h.

N04a00020003000400050006000700020009000
000200030004000500066¢ 15

00020030002f 002=00000411

Option 6: Stop periodically transmit
Option 7: Puts the end-device into sleep for 5 sec (PMM Standby mode, refer to 5.2 Sleep Mode)
Option 8: Print app information and Join Parameters

Option 9: Resets the board (soft Reset)

Note : Option 1-2, 5-9 same as 3.5 Demo Application Usage(form 3 Example Demo Project)
5 Setting Project / Properties

5.1 EUI Address

Go to Project > Properties

3 LORAWAN P6_MODBUS_DEMO_V1 - Microchip Studio Advanced Mode (1Y’
File Edit  View VAssistX  ASF Project | Build Debug Tools  Window Help
0-0 /8- -2 ud @ I

W@ > t a2

Atmel Start Project

T S rted il
R o-d@| p=q
B
o]
b [ Dependencies
b [ Output Files [}‘ DEMO_V1 Properties AltsF7 ] e
4 Libraries

sleeph ® X =

e Configuration: | Active (Debug Platform:  Active (ARM:
Build Events
Device -

# 5] ARM/GNU Common ARM/GNU C Compiler = Symbols
Too General ——
Packs Defined symbols (-D) [ %

a
Advanced ENABLE_PDS=1

TC_ASYNC=true

SAMR34)188B.

Undefined symbols (-U) ¢ K

o General
& Debugging

15
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Double click at EDBG_EUI_READ, define EDBG_EUI_READ as 1 to read DevEUI from EUI-48 MAC Address and

set it.

ARM/GNU C Compiler = Symbols

Otherwise the value DEMO_DEVICE_EUI and DEMO_DEVICE_ADDRESS

/* ABP loin Parameters */

|Hde\"ine DEMO_DEVICE_ADDRESS

Bxabcd@001 I«
{8x18, exbe, 8xi8,

Defined symbols (-D) <) 2
ARM_MATH_C -

EXTINT_CALL Edit Defined symbols (-0} e |
BOARD=SAMR? Defined symbols (-D)

IND_BAND=0 | [ED8G_FuLREAD=1 | €=
USART_CALL

EDBG_EUI_REA

DEMO_APP_E Cancel
|Undeﬂned symbols (-U) |@| =]

configured in conf_app.h.

#define DEMO_APPLICATION_SESSION_KEY Bx90, 0x30, 0x00, Ox48, Ox20, Ox50, 0x00, Ox60, 6x00, ©x70, OxP8, 0x80, Ox0A}
#define DEMO_NETWORK_SESSION_KEY {ex10, Ox00, Ox20, 0x00, 0x30, 0x00, Ox40, 0x00, Ox50, Ox00, Ox60, 0x00, Ox70, Ox00, Ox80, Ox0A}
/* OTAA Join Parameters */

|#define DEMO DEVICE EUT {0x00, Ox01, 0x00, 0x00, 8x35, OxBf, 0x00, 0x00) | <

#define DEMO_APPLICATION_EUL {0x00, 0x00, 0x00, Ox00, Ox00, Ox00, Ox00, Ox05)

#define DEMO_APPLICATION KEY {0x00, 0x00, 9x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x05)

5.2 Sleep Mode

Go to Project > Properties, select toolchain, Go to ARM/GNU C Complier > Symbols

add or remove CONF_PMM_ENABLE macro from Defined symbol for disable/enable Sleep mode function.

-

Platform: |Active (ARM)

-

(1]
}

“ || ARM/GNU € Compiler = Symbols

Defined symbols (-D)

| =

wlafEf [

—_

il
il Configuration: Active (Debug)
Build Events
Configuration Manager...
Device
4 | ARM/GNU Common
Tool F General
Packs = Output Files
4 [ ARM/GNU C Compiler
Advanced

Edit Defined symbols (-D)

Defined symbols (-D)

|

CONF_USB_ENABLE

.

] <— @
[ ox ][ cancer ]

Go to conf_pmm.h and for setting CONF_PMM_SLEEPMODE_WHEN_IDLE

/=

* This macro specifies the sleep mode to use when node is in IDLE

* mode i.e., when no transaction is happening.
*f

| #define CONF_PMM_SLEEPMODE_WHEN_IDLE SLEEP_MODE_STANDBY

// #define CONF_PMM_SLEEPMODE_WHEN_IDLE

SLEEP_MODE_BACKUP

and go to conf_app.h for setting sleep duration. By default, configured in 5000 msec.

/* This macro defines the application's default sleep duration im milliseconds */

#define DEMO_CONF_DEFAULT_APP_SLEEP_TIME_MS

seee
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5.3 Modbus

5.3.1 Modbus request Commands

Go to..\src\modbus_app.c, set Slave Id, Function, Start address, Quantity of Registers in Device_t

Slave (in example limit maximum 10 commands)

In Example, 5 request commands are follows:

Request NO.
1 2 3 q 5
Field Name Variable Name
Slave ID Slave.id 0x01 0x01 0x01 0x01 0x01
Function Code Slave.func 0x03 0x03 0x03 0x03 0x03
Starting Address Slave.Addr 0x0000 0x0001 0x0013 0x0001 0x0018
Quantity of input Registers Salve.data 0x000A 0x0005 0x000A 0x0005 0x0006

typedef struct Device t{
const uint8_t id;
uint8_t status;
uint8_t func;
uint16_t addr;
uint8_t data;
uint8_t buffer[MODBUS_DATA_BUFFER_MAX];
uint8_t size;

}Device_t;
Device_t Slave[MODBUS_DEVICE_TOTAL] = { [{1, @, MB_READ_HOLDING_REGISTERS, @, 10},
{1, ©, MB_READ HOLDING REGISTERS, 1, 5},
{3, ©, MB_READ HOLDING REGISTERS, 19, 10}, <
{4, @, MB_READ_HOLDING_REGISTERS, 1, 5},
{5, @, MB_READ HOLDING_REGISTERS, 27, 6},
{6, 0, 0,0, 0} };
5.3.2 Response Payload
In Example, uplink payload formats is follow:
Payload No. Error Status Modbus Response
1 Byte 1 Byte N Bytes
Byte Value Description

Payload No. | 01 Payload No. 0x01 to Oxff

Error Status (Binary format)
bit 0 : Modbus timeout

bit 1 : CRC Failed

Error Status 00 bit 2: Response Failed
bit 3: Request parameter
Failed

E.g. 0x00 = no error

Message 01031400aa00020003000400050006000700080009000a8b2a | Modbus response for request

command no.1
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Go to “..\src\enddevice.c”, see in function static void insert_data_modbus(void)

- static void insert_data_modbus(void){
uint8_t slave_id = 1;

if(@<(mbReceivedSize=getSlaveResponse(mbReceivedBuffer+l,slave_id))){
mbReceivedBuffer[@] = getSlaveStatus(slave_id);
mbReceivedSize += 1;

}
else{
memset(mbReceivedBuffer,d,3);
mbReceivedBuffer[1] =0xff;
3
}
5.4 LEDs

Go to ..\src\config\conf_app.h define DEMO_LED_STATUS for enable, or undefined for disable led status

option.

/* This macro enables or disables the LED indications */
|| #define DEMO_LED_STATUS |

5.5 Watchdog Timer
Go to ..\src\config\conf_enddevice.h define CONF_WDT_ENABLE for enable, or undefined for disable

watchdog function.
f* WOT */
|| #define COMF_WDT ENABLE |
—#ifdef CONF_WDT_ENABLE
#define APP_PERIOD_WDT_CLEAR (1800u)
gendif //CONF_WDT_EMABLE

5.6 USB

Go to Project > Properties, select toolchain, Go to ARM/GNU C Complier > Symbols
Double click at CONF_USB_ENABLE, define CONF_USB_ENABLE as 1, for enable USB function.

Build

Configuration: Active (Debug) ~  Platform: 'Active (ARM)
Build Events
Configuration Manager..
Device = i B
4 |=] ARM/GNU Common ARM/GNU C Compiler = Symbols
Tool o General T = o
Packs = Output Files Defined symbols (-D)
4 [ ARM/GNU C Compiler |
Advanced
Edit Defined symbols (-D) X |
Defined symbols (-D)
|| Jeone use_enasLe=1 | D ol
. [ ox|[comel]
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6 Appendix

6.1 Board Dimensions

71.00 mm
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6.2 Board Layout

LoRa_SAMR34A EVA MODBUS Layout
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7

8

6.4 Optional Accessories

Evaluation Board Modbus R5485 to LoRaWAN (Cover Standard Din Rail)

P/N

Description

0271113MCF-100

RF Cable convert SMA Female Bulkhead to MCF Male

BY-GSM-01 48 MM.

48mm, Connector SMA Right Angle Male

GSM Antenna, Frequency 850-1900/900-1800/2100 MHz Antenna Length

2201819

mm DIN Rail Application

Electronic Housing, Mounting Base Housing, Material ABS,Size 75.4x70.2x46

2201830

mm(WxL) DIN Rail Application

Electronic Housing,Upper Part Housing Cover =aterial ABS,Size 75.4x70.2

Reference Links

e LoRa SAMR34A V4.1 module

e LoRa SAMR34 EVA(ES) - Documentation page and source code

e SAM R34/R35 L ow Power LoRa Sub-GHz SiP Datasheet

e Microchip RF tools for LoRa - RF tool can be used for detailed testing and RF certification

e SAM R34 MLS Getting Started Guide

Reversion History

Revision

Description

Date

1.0

Initial version

06-07-2022
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