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Warranty and Disclaimer 

The use of the deliverables (e.g. software, application examples, target boards, evaluation boards, starter kits, schematics, 
engineering samples of IC’s etc.) is subject to the conditions of Fujitsu Semiconductor Europe GmbH ("FSEU") as set out in (i) 
the terms of the License Agreement and/or the Sale and Purchase Agreement under which agreements the Product has been 
delivered, (ii) the technical descriptions and (iii) all accompanying written materials. 

Please note that the deliverables are intended for and must only be used for reference in an evaluation laboratory environment. 

The software deliverables are provided on an as-is basis without charge and are subject to alterations. It is the user’s obligation 
to fully test the software in its environment and to ensure proper functionality, qualification and compliance with component 
specifications. 

Regarding hardware deliverables, FSEU warrants that they will be free from defects in material and workmanship under use and 
service as specified in the accompanying written materials for a duration of 1 year from the date of receipt by the customer. 

Should a hardware deliverable turn out to be defect, FSEU’s entire liability and the customer’s exclusive remedy shall be, at 
FSEU´s sole discretion, either return of the purchase price and the license fee, or replacement of the hardware deliverable or 
parts thereof, if the deliverable is returned to FSEU in original packing and without further defects resulting from the customer’s 
use or the transport. However, this warranty is excluded if the defect has resulted from an accident not attributable to FSEU, or 
abuse or misapplication attributable to the customer or any other third party not relating to FSEU or to unauthorised decompiling 
and/or reverse engineering and/or disassembling. 

FSEU does not warrant that the deliverables do not infringe any third party intellectual property right (IPR). In the event that the 
deliverables infringe a third party IPR it is the sole responsibility of the customer to obtain necessary licenses to continue the 
usage of the deliverable. 

In the event the software deliverables include the use of open source components, the provisions of the governing open source 
license agreement shall apply with respect to such software deliverables.  

To the maximum extent permitted by applicable law FSEU disclaims all other warranties, whether express or implied, in 
particular, but not limited to, warranties of merchantability and fitness for a particular purpose for which the deliverables are not 
designated. 

To the maximum extent permitted by applicable law, FSEU’s liability is restricted to intention and gross negligence. FSEU is not 
liable for consequential damages. 

Should one of the above stipulations be or become invalid and/or unenforceable, the remaining stipulations shall stay in full 
effect. 

The contents of this document are subject to change without a prior notice, thus contact FSEU about the latest one. 
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Information 

 
Note: 
For viewing PDFs on this CDROM / softwarepackage "PDF XChange 
Viewer" is included. PDF XChange is used as PDF viewer to support 
hyperlinks to content located at CDROM or this softwarepackage. 
 
PDF XChange Viewer is free of charge and can be downloaded at the 
website of the manufacturer "Tracker Software": 
http://www.tracker-software.com/product/pdf-xchange-viewer 
 
 
Fujitsu Semiconductor Europe (FSEU) is NOT selling or reselling PDF 
XChange. Please directly contact the manufacturer:  
http://www.tracker-software.com 
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CD Contents 

 Software (Installation)     
 FLASH USB DIRECT Programmer  (utilities\programmer_usb\setup.exe) 
 FLASH Serial Programmer  (utilities\programmer_uart\setup.exe) 
 SerialPortViewerAndTerminal   (utilities\serial_port_viewer\setup.exe) 
 Fujitsu OpenOCD Starter (GUI) (utilities\openocd_starter\setup.exe) 
 Fujitsu USB Wizard download via http://emea.fujitsu.com/fm3 

 Documents 
 Schematic:          ‘SK-FM3-48PMC-USBSTICK’  
 User Guide:         ‘SK-FM3-48PMC-USBSTICK’  
 Data Sheet:          MB9A310K Series 
 Manual:                Peripheral Manual 
 Manual:                Technical Reference Manual 
 Manual:                Flash Programming Manual 
 Application Note: Virtual Com Port; Example Files: Virtual Com Port 
 Application Note: FSEU USB Host 
 Application Note: FujitsuUsbLib (PC) 
 Application Note: FSEU Embedded USB Device Library 
 Application Note: OpenOCD GUI Frontend 
 Application Note: USB Host Mass Storage Bootloader; Example Files: Firmware 
 Doxygen Documentation USB 
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CD Contents (continued) 

 Examples 
 Host / Device switchable: Host: Mass Storage, Keyboard, Mouse; Device: LibUSB  

sk-fm3-48pmc-usbstick_usb_device_libusb_communication-v12   Driver  / Win-Exe /  Firmware 
 

 Host / Device switchable: Host: Mass Storage, Keyboard, Mouse; Device: Virtual Com Port 
sk-fm3-48pmc-usbstick_usb_device_virtual_com_port-v12         Driver  /  Firmware 

 
 Host / Device switchable: Host: Mass Storage, Keyboard, Mouse; Device: HID communication 

sk-fm3-48pmc-usbstick_usb_device_hid_communication-v12       Win-Exe / Firmware 
 

 USB Host Mass Storage Bootloader: 
sk-fm3-48pmc-usbstick_usb_host_massstorage_bootloader-v10   Firmware 
 

 
 Compiled code can be found in subfolder example\IAR\output\release\exe 

 
 Please copy examples folder on CD to harddrive before using them! 

 
 Click here to start installation of contents from CD to hard drive 

 
 Have a look for the latest version: http://emea.fujitsu.com/fm3 
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CD Contents (continued) 

 

 
 
 
 

Download the latest version from the following website 

http://emea.fujitsu.com/fm3 
 
 

Direct Tool URL: 
http://mcu.emea.fujitsu.com/mcu_tool/detail/SK-FM3-48PMC-USBSTICK.htm 
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Overview 

 Introduction 
 About the SK-FM3-48PMC-USBSTICK 
 Requirements 
 The hardware 
 Installation of Serial Port Viewer & Terminal 
 Installation of USB drivers 
 

 Try yourself 
 MCU Programming via USB 
 USB Host and Device 
 Debugging 
 IAR-Embedded Workbench 
 Keil µVision 

 
 Create Own USB Applications using Fujitsu USB Wizard 

 
 Contacts 
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7 

NEW 



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics 

About the SK-FM3-48PMC-USBSTICK 

 The SK-FM3-48PMC-USBSTICK includes a low-cost evaluation 
board  
based on the Fujitsu FM3 microcontroller MB9A310k Series 
 

 The MB9A310K Series includes the following features: 
 Up to 128 KByte Flash Memory 
 Up to 16 KByte RAM 
 Up to 4 LIN-USART-I²C interfaces 
 USB-Host/-Device interface 
 Timers (ICUs, OCUs,  PPGs, others) 
 Up to three 12 bit ADC 
 External interrupts 
 Low Power Mode 
 DMA Controller (8 channels) 
 Quadrature Position/Revolution Counter 
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About the SK-FM3-48PMC-USBSTICK 

 Features of the SK-FM3-48PMC-USBSTICK board: 
 
 Microcontroller MB9AF312K 
 1x USB to serial converter (Type-B connector) 
 JTAG integrated 
 1x USB-MiniHost (Type-A connector) 
 1x USB-Device (Type-B connector) 
 Optional USB On-The-Go (assembly option for USB Mini connector) 
 3x LED controlled with PWM 
 1x ‘User’-button 
 1x ‘Reset’-button 
 All 48 pins routed to pin-header 
 Power supply via USB  
 Voltage filter for ADC 
 Light sensor 
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Requirements 

 Embedded Development & MCU Flash Programming 
 Windows 2000 , Windows XP or Windows7 
 Administrator Rights 
 For some applications .NET Framework 2.0 and higher is required 

 
 PC Frontend Development 

 Microsoft Visual C# Express 
 Microsoft .NET Framework 2.0 and higher 

 
 Virtual Com Port Example 

 Windows 2000,XP, Vista or Windows 7 (32-bit) 
 Mac OS X or Linux 

 
 HID Communication Example 

 Windows 2000,XP, Vista or Windows 7 (32- and 64-bit) 
 Microsoft .NET Framework 3.5 and higher 
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Top side 

USB-Connector 
(X6) 
USB A/B conector  

Voltage Regulator 
For internal 3,3V 

Run/Prog Switch 
To switch between USB 
programming mode and 
run mode 

Pin Headers 
Connect free MCU Pins 
with own peripherals 

FM3 MB9AF312K 
Series MCU 
MB9AF312K 4MHz Oszillator 

Reset button 

RGB LED 

User Button 

Light Sensor 

JTAG 

Chip 

Pin Headers for UART 

Pin Headers for JTAG 

JTAG USB 
(X5)  

Debug 
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The Hardware 
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Pin Pin-name 
Pin-Function on  
SK-FM-100PMC  

Pin Pin-name 
Pin-Function on  
SK-FM-100PMC  

1 VCC VCC 13 C N.C. 

2 P50/ INT00_0/AIN0_2/ SIN3_1 14 VCC VCC 

3 P51/INT01_0/BIN0_2/SOT3_1 15 P46/ X0A 32KHz Crystal 

4 P52/INT02_0/ZIN0_2/SCK3_1 16 P47/ X1A 32KHz Crystal 

5 P39/DTTI0X_0/ADTG_2 17 INITX Reset 

6 P3A/RTO00_0/TIOA0_1/RTCCO_2/SUBOU
T_2 R-RGB LED 18 P49/ TIOB0_0 

7 P3B/RTO01_0/TIOA1_1 19 P4A/ TIOB1_0 

8 P3C /RTO02_0 /TIOA2_1 G-RGB LED 20 PE0/ MD1   

9 P3D/ RTO03_0/ TIOA3_1 21 MD0 SW3 
Run Mode 

10 P3E/ RTO04_0/ TIOA4_1 B-RGB LED 22 PE2 
X0 4MHz Crystal 

11 P3F/ RTO05_0/ TIOA5_1 23 PE3 
X1 4MHz Crystal 

12 VSS GND 24 VSS GND 

• The microcontroller pins 
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The Hardware 
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Pin Pin-name 
Pin-Function on  
SK-FM-100PMC  

Pin Pin-name 
Pin-Function on  
SK-FM-100PMC  

25 P10/ AN00 Fotoresistor LDR 
03 37 P00/ TRSTX TRSTX 

26 P11/ AN01/SIN1_1 /INT02_1/ FRCK0_2/ 
IC02_0/ WKUP1 USB Overcurrent 38 P01 /TCK / SWCLK TCK 

27 P12/ AN02/ SOT1_1/ IC00_2 USB HOST Pull-
Down 39 P02 /TDI TDI 

28 P13/ AN03/ SCK1_1/ IC01_2/ RTCCO_1/ 
SUBOUT_1 USB VBUS EN 40 P03 / TMS / SWDIO TMS 

29 P14/ AN04/ SIN0_1/ INT03_1/ IC02_2 41 P04 /TDO /SWO TDO 

30 P15/ AN05/ SOT0_1/ IC03_2 USB ID 42 P0F/ NMIX / CROUT_1 / RTCCO_0 
/SUBOUT_0 / WKUP0 

SW2  
Switch 

31 AVCC VCC 43 P61 / SOT5_0 / TIOB2_2 / UHCONX 
/DTTI0X_2 UHCONX 

32 AVRH VCC 44 P60 / SIN5_0/ TIOA2_2 / INT15_1/ IC00_0/ 
WKUP3 USB VBUS INT 

33 AVSS GND 45 USBVCC VCC 

34 P23/ AN06/ SCK0_0/ TIOA7_1 46 P80/ UDM0 UDM0 

35 P22 / AN07 / SOT0_0 / TIOB7_1 UART0 (TXD) 47 P81 /UDP0 UDP0 

36 P21 / SIN0_0 / INT06_1 / WKUP2 UART0 (RXD) 48 VSS GND 

• The microcontroller pins (continued) 
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JP1- JP2: JTAGPWR 
Default:Closed 

JP3: Use SW1  
Default:Closed 

JP4, JP5, JP8: RGB LEDs  
Default:Closed 

JP6: Light Sensor 
Default:Closed 

JP7: USB ID-Pin 
Default:Closed 

JP9: USB BUS low/high 
Default:2-3 

JP10: USB BUS Enable 
Default:Closed 

JP11: AVRH Enable 
Default:Closed 

JP12: USB Overcurrent 
Default:Closed 

JP13: USB Host Low 
Default:closed 

JP14-JP15: Use  32KHz 
Quartz 
Default:Open 
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The Hardware  
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• The Jumpers 
 

Jumper Function Default 

JP1 JTAGPWR Closed 

JP2 JTAGPWR Closed 

JP3 Use SW1 Closed 

JP4 RGB LEDs Closed 

JP5 RGB LEDs Closed 

JP6 Light sensor Closed 

JP7 USB ID Pin Closed 

JP8 RGB LEDs Closed 

JP9 USB BUS low/high 2-3 

JP10 USB BUS enable Closed 

JP11 AVRH Enable Closed 

JP12 USB Overcurrent Closed 

JP13 USB Host Closed 

JP14 Use 32KHz Crystal Open 

JP15 Use 32KHz Crystal Open 
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    Note: 
    Have also a look into the tools user 
    guide to have detailed information 
    about hardware components and 
    how to use it. 
 
    User Guide SK-FM3-48PMC-USBSTICK 
 

The Hardware 
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MCU Programming via USB 

 Step 1 
 Insert the CD ROM 

 
 Switch SW3 to Prog Mode 

 
 

 
 

 Step 2 
 Connect the evaluation board 

to the PC 
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 Step 3 
 The hardware wizard will be 

opened. 
 Select "No, not this time" and 

click "Next" 
 
 
 
 

 Select "Install the software 
automatically 
(Recommended)" and click 
"Next" 
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MCU Programming via USB 
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 Step 3 (continued) 
 While asking for Windows 

Logo certification, click 
"Continue Anyway" 

 
 
 

 The driver installation was 
successful. 
 
 

 Step 4 
 
 Click finish 
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MCU Programming via USB 
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 Step 5 
 Find the virtual com port 

number via the device 
manager. It can be found in 
the "System" Control Panel. 
 
 

 Select the "Hardware" and 
click at "Device Manager" 
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MCU Programming via USB 
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 Step 5 (continued) 
 Open the tree "Ports (COM & 

LPT" by clicking on the "+". 
 

 Look for the "USB Port" entry. 
In this case it is com port 4 
 
 
 
 
 
 
 

 
 
 

All Rights Reserved.© Fujitsu Limited 2012 

21 

 

MCU Programming via USB 



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics 

MCU Programming via USB 

 Step 5 
 Start the installation  

(utilities\ programmer_usb\setup.exe)  
USB DIRECT Programmer 
 

 Click "Next" 
 
 
 
 

 Choose a optional installation 
directory and click "Next" 
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MCU Programming via USB 

 Step 5 (continued) 
 The USB DIRECT 

Programmer was now 
succesfull installed. 
 
 
 
 
 
 

 Step 6 
 Start the USB DIRECT 

Programmer from Start Menu 
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MCU Programming via USB 

 Step 7 
 Choose Target MCU 
 Enter the com port number 

 
 

 Open the firmware file 
• Located in: 

Examples\ 
sk-fm3-48pmc-usbstick_usb_device_hid_communication\ 
Example\IAR\output\release\exe 

• Choose here 
sk-fm3-48pmc-usbstick_usb_device_hid_communication.srec 
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MCU Programming via USB 

 Step 7 (continued) 
 Click at "Full Operation" 

 
 
 
 
 

 Reset the MCU and click at 
"OK" 
 
 
 
 

 The firmware was 
programmed. 
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MCU Programming via USB 

 Step 8 
 
 

 Switch SW3 to RUN 
 
 
 
 
 
 
 
 
 

 Press the reset button 
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Installation of Serial Port Viewer 
& Terminal 

 
 Start Installation 

Serial Port Viewer & Terminal  
(utilities\serial_port_viewer\setup.exe) 

 
 Click "Next" 

 
 
 
 
 

 Read and accept the 
disclaimer and click "Next" 
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Installation of Serial Port Viewer 
& Terminal 

 
 Choose a optional installation 

directory and click "Next" 
 
 
 
 

 
 
 
 
 

 Click "Next" 
 

 
 
 

All Rights Reserved.© Fujitsu Limited 2012 

28 



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics 

Installation of Serial Port Viewer 
& Terminal 

 
 

 Click "Install" 
 
 
 

 
 
 
 
 

 Click "Finish" and the Serial 
Port Viewer & Terminal will be 
opened. 
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Installation of Serial Port Viewer 
& Terminal 

 
 The Serial Port Viewer & 

Terminal can be found as tray 
icon. Via right-click, the 
terminal for the specific com 
port can be opened. 
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1 2 

 
 
 
 
 
 

 
 

 1. Select Baud rate (Default 
baudrate in examples is: 115200) 

 2. Click red blinking "Disconnected" 
button to connect 
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Virtual Com Port Example 

 Used to communicate via 
CDC class 

 MCU source & binary 
Examples\ sk-fm3-48pmc-
usbstick_usb_device_virtual
_com_port-v12 
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USB Host and Device (1) 

 Device Mode: 
 HID Communication 

 
 
 

 
 Host Mode: 

 Mass Storage 
 Mouse 
 Keyboard 

 
 
 

 Example: 
sk-fm3-48pmc-usbstick_usb_host_device-vXX 
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USB Host and Device (2) 
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 USB Device connected to PC 
 LEDs turns off 
 Within example sk-fm3-48pmc-usbstick_usb_device_hid_communication-v12 

in folder "forwindows\Binary" the PC Demo can be found: 
"Fujitsu_UsbCom_Demo.exe" 

 LEDs, Sensors, Buttons and UART can be used via GUI 
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USB Host and Device (3) 
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 USB Mass Storage via Host 
 Red LED turns on after a few seconds 
 Content of USB Stick will be displayed via UART 0 (X5), 115200,8,N,1 
 fujitsu.txt file will be written 
 Red LED turns off and green LED turs on for ready to disconnect 
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USB Host and Device (4) 
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 USB Mouse via Host 
 Green LED turns on after a view seconds 
 Position will be displayed via UART 0 (X5), 115200,8,N,1 
 LEDs can be dimmed via X/Y movement and scroll wheel 
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USB Host and Device (5) 
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 USB Keyboard via Host 
 Green LED turns on after a few seconds 
 Text typed will be displayed via UART 0 (X5), 115200,8,N,1 
 LEDs can be switched via key 1-3 
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Create own USB Applications 
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 Using the Fujitsu USB Wizard 
 Easy to use, step by step 
 Creates USB Host / Device Projects 
 Combines microcontroller templates, board support and USB use case 
 Download the newest version from internet (http://emea.fujitsu.com/fm3) 
 Start Installation (utilities\usb_wizard\setup.exe) 
 

NEW 

Easy to use 
Wizard 

Detailed 
Configuration 

Application 
Notes 

 

http://mcu.emea.fujitsu.com/mcu_tool/detail/FUJITSU_USB_WIZARD.htm�
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Installation of the USB-driver 

 Install Fujitsu OpenOCD Starter (min. V1.2) 
 Run Installation (utilities/openocd_starter/setup.exe) 

38 
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Installation of the USB-driver 

 Install Drivers during Installation 
 
 
 
 
 
 
 
 
 1) Select „Install Drivers“ and „Run OpenOCD at startup“ 
 2) Plug in the evaluation board at USB DEBUG (X13) and click ‚OK‘ 
 3) Select target board „.\sk-fm3-48pmc-usbstick.cfg“ and click ‚Start‘ to 

run OpenOCD GDB Server 
 
 
 
 
 

39 
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Installation of the USB-driver 

 (Optional) Install Drivers after Installation 
 Run Fujitsu OpenOCD Starter (normally started in background) 

 
 
 
 Connect the evaluation board and wait for following pop-up window  

 (If connected, disconnect and connect again) 
 
 
 
 
 Select „\sk-fm3-48pmc-usbstick.cfg“ and click „Run & Install Drivers“ 
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Deinstallation of the USB-driver 

 (Optional) Uninstall Drivers after Installation 
 Run Fujitsu OpenOCD Starter (normally started in background) 

 
 
 
 Connect the evaluation board and wait for following pop-up window 

(If connected, disconnect and connect again) 
 
 
 
 
 Select „\sk-fm3-48pmc-usbstick.cfg“ and click  

„Remove LibUSB Drivers“ 
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Debugging via JTAG 

 The MB9AF312K microcontroller offers a JTAG-Interface 
that is supported by SK-FM3-48PMC-USBSTICK. 
 To debug your program, the on-board OpenOCD compatible USB to 

JTAG adapter can be used (X5). It offers USB to one port JTAG 
interface and one port UART interface.  

 See also Install Drivers 
 After connecting the evaluation board to the PC, following dialog should 

pop-up: 
 
 
 
 
 

 Choose „sk-fm3-48pmc-usbstick.cfg“ and click „Start“ 
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Debugging via JTAG 

 The MB9AF312K microcontroller offers a JTAG-Interface 
that is supported by SK-FM3-48PMC-USBSTICK. 
 To debug your program with a JTAG-Adapter e.g. Segger J-Link 
 Connect the J-Link to the JTAG-Interface routed to the 20-Pin-Header 

on X1 and to the USB-Port of your PC 
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IAR-Embedded Workbench / 
KEIL µVision IDE and Debugger  

 
 Installation 
 Getting Started 
 Open Project 
 Build Project 
 Debug Project 
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IAR Workbench Getting Started 

 Install EWARM from IAR-CD or download latest version from 
IAR Website 
 EWARM 30-day Evaluation Version 

• http://supp.iar.com/Download/SW/?item=EWARM-EVAL 
 EWARM 32K Kickstart Version 

• http://supp.iar.com/Download/SW/?item=EWARM-KS32  
 

 Start EWARM Workbench 
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IAR Workbench Getting Started 
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 Choose File → Open → Workspace 
 Select e.g.\Examples\sk-fm3-48pmc-

usbstick_usb_device_hid_communication-vXX\example\IAR\sk-
fm3-48pmc-usbstick_usb_device_hid_communication.eww   
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IAR Workbench – Main Window 
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 IAR Workbench 
 Workspace on left side 

of Workbench window 
• Choose: 

View→Workspace, 
if hidden 

 Source files on right 
side of Workbench 
window as tabbed 
windows 

 
 Project can 

alternatively be 
opened by: 
File→Open→ 
Workspace→*.eww  
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IAR Workbench – Menu Bar 

 Menu Bar 
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File Control 
(new, open, 
save, etc.) 

Edit Control 
(cut, copy, 
paste, undo, 
redo) 

Configuration 
Control 
(e.g. RAM or ROM 
debugging) 

Navigation Control 
(Find, Bookmarks, File 
Navigation, etc.) 

Build Control 
(compile, make, 
stop build) 

Debug Control 
(Breakpoint, start 
Debug w/ and w/o 
download) 
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IAR Workbench – Workspace 

 IAR Workspace Window 
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Project Name 

Sub Folder Modules 

Main Modules 

Module Includes 

Project Description 

Project Built Output 
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IAR Workbench - OpenOCD (GDB) 

 Setup OpenOCD Debugger 
 Install drivers of OpenOCD Starter 

 
 (A) Run & Install Drivers 

 
 
 
 
 

 (B) Start OpenOCD GDB Server 
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IAR Workbench - OpenOCD (GDB) 

 OpenOCD / GDB Server usage 
 Mark Project File in Workspace 
 Choose Project→Options 
 Choose GDB Server in Debugger Setup 
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 OpenOCD / GDB Server usage 
 Set GDB TCP/IP Address: 127.0.0.1 
 Start GDB Debugger with usual      Icon 

 
 

IAR Workbench - OpenOCD (GDB) 
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IAR Workbench – Making Project 

 Making the Project 
 Use Make-Icon (      ), <F7> or 

Menu: Project→Make 
 Check for no errors in Output window 

below 
 
 

 Build errors are indicated by       or 
In Output window and Source view 
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IAR Workbench – Download to 
Target 
 Download to Target and Start Debugging 

 Use       Icon, <Ctrl>-D, or Project→Download and Debug 
 A new menu bar will occur on sucessful connection to target 
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Reset 
Target 

Stop 

Step 
Over 

Step 
Into 

Step 
Out 

Next 
Statement 

Run to 
Cursor 

Run 

End 
Debugging 

Trace 
Control 
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IAR Workbench – Debug (1) 

 Source Window 
 The Source windows do not change contents but get additional 

information 
• Current line (PC): 
• Halted on Breakpoint: 
• Halted on Data break (example):   

 Disassembly Window 
 Shows ‘pure‘ disassebly view 
 Shows mixed mode view 
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IAR Workbench – Debug (2) 

 Watch Window 
 Watch 

• Expressions/Variables have to be added by user and are updated 
by Halt/Breakpoint 

 
 
 
 

 Quick Watch 
• The Quick watch allows the user to calculate and recalculate 

expressions even with variables 
 
 
 
 

 
• The drop down menu memorizes the last typed contents 
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IAR Workbench – Simulator 

 Simulator 
 Mark Project File in Workspace 
 Choose Project→Options 
 Choose Simulator in Debugger Setup 
 Start Simulator with usual      Icon 
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KEIL µVision IDE and Debugger 
Getting Started 
 
 Install µVision from KEIL-CD or download latest version from 

KEIL Website 
 Evalualtion Version 

• https://www.keil.com/demo/eval/arm.htm 
• Registration required 

 
 Install Colink Plugin for Keil RealView MDK  

(for OpenOCD usage) 
 http://www.coocox.net/CoLinkGuide/CoMDKPlugin.html 

 
 

 Start µVision 
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KEIL µVision – Getting Started 

 Choose Menu: Project→Open Project... 
 Browse to: Examples\mb9afb4xn_lcd_counter-vXX\example\ARM\ 
 Choose mb9afb4xn_lcd_counter.uvproj 
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KEIL µVision – Main Window 

 KEIL µVision 
 Project window on left side of 

IDE window 
• Choose: 

View→Project Window 
if hidden 

 Source files on right side 
of IDE window as tabbed 
windows 

 Output window on bottom 
side of IDE window  
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KEIL µVision – Menu Bars (1) 

 Menu Bar 1 
 Can be moved in bar window area or set floating 
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File Control 
(new, open, 
save, etc.) 

Edit Control 
(cut, copy, paste, etc) 
(indention, commenting) 

Navigation Control 
(Bookmarks + search, etc.) 
(Text search, search in files, etc.) 

Debug Control 
(Start/Stop Debug Session, 
set/remove/disable 
breakpoints, remove/disable 
all breakpoints) 

Project 
Window View 

IDE 
Configuration 



Fujitsu Semiconductor Europe - http://emea.fujitsu.com/microelectronics 

KEIL µVision – Menu Bars (2) 

 Menu Bar 2 
 Can be moved in bar window area or set floating 
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Build Control 
(Compile [Translate], 
Build, Rebuild, etc.) 

Download 
to Target 

Configuration 
Control 
(e.g. RAM or ROM 
debugging) 

Target 
Options 

Manage Books, 
File Extensions, 
Environment 

Manage 
Multi-
Project 
Workspace 
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KEIL µVision – Project Window 

 µVision Project Window 
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Project Name 

Startup Code Subfolder 

Startup Code Source and 
HeaderFiles 

Main Project Code Subfolder 

Main Project Code Source and 
Header Files 

Project Description Subfolder and 
Abstract File 
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KEIL µVision – Setup OpenOCD 

 Setup OpenOCD Debugger 
 Deinstall drivers of OpenOCD Starter 

 
 (A) Cancel installation of drivers 

 
 
 
 
 

 (B) deinstall drivers at evaluation board connection 
 
 
 
 
 

 Install Colink Plugin for Keil RealView MDK  
(for OpenOCD usage) 
http://www.coocox.net/CoLinkGuide/CoMDKPlugin.html 
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KEIL µVision – Setup OpenOCD 

 Setup OpenOCD Debugger 
 Open Project Settings 

Project→Options for Target ‚MB9AF312K_...‘... 
 Select Debug Tab 
 Select CooCox Debugger 
 Click Settings 
 Choose Adapter Olimex-OpenOCD 
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KEIL µVision – Setup OpenOCD 

 Setup OpenOCD Debugger (continued) 
 Choose Flash Download Tab 
 Click Add 
 Choose MB9xFxx2 device 
 Click OK 
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KEIL µVision – Setup OpenOCD 

 Setup OpenOCD Debugger (continued) 
 Open Project Settings 

Project→Options for Target ‚MB9AF312K_...‘... 
 Select UtilitiesTab 
 Select CooCox Debugger 
 Click Settings 
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KEIL µVision – Making Project 

 Making the Project 
 Use Rebuild Icon 

(      ) or 
Project→Rebuild all target 
files 

 Check for no errors in 
Output window below 
 

 Build errors are shown in Output window. 
• Can be double-clicked by showing the source line with a blue arrow 
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KEIL µVision – Debug (1) 

 Start Debugging 
 Download to target first, when MCU Flash does not contain the current 

application openend and built in the IDE 
• Use Download Icon (      ) or Menu: Flash→Download 

 Start Debug Session 
• Use Start/Stop Debug Icon (       ) or Menu: Debug→Start/Stop 

Debug Session 
 Ending Debug Session 

• Use same way as for starting debug session 
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KEIL µVision – Debug (2) 

 Debugging Icon Bar 
 During a Debug Session there will be visible a new icon bar 
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Reset 
Target 

Start/ 
Stop 
Application 

Step Control 
(Step in, out, etc.) 

Show 
Source/Code 
Line of current 
PC 

Show Windows (Command, 
Disassembly, Symbols, 
Registers, Call Stack) 

Show (multiple) 
Windows 
(Watch, Memory, Serial, 
Analysis, Trace, System 
Viewer) 

Tool Box 
(can be 
customized) 

Debug 
Restore 
Views 
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KEIL µVision – Debug (3) 

 Source View 
 The Source windows do not change contents but get additional 

information 
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Active Breakpoint 

Disabled Breakpoint 

Current Program 
Counter 

Current Cursor Line of 
Source Code 

Code Lines with 
compiled Instructions 
(dark grey    ) 
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KEIL µVision – Debug (4) 

 Disassembly View 
 Mixed mode is selectable and deselectable 

 

All Rights Reserved.© Fujitsu Limited 2010 

72 

Active Breakpoint 

Disabled Breakpoint 

Current Program 
Counter 

Current Cursor Line of 
Code highlighted in 
yellow background (   ) 
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KEIL µVision – Debug (5) 

 Memory Window 
 Up to 4 Memory windows can be displayed in tabs 
 Memory is updated during runtime 
 Memory window tabs are shared with Watch windows 

 
 
 
 
 
 

 Register View 
 Register view is a tab of the Project window 
 Changes are highlighted in dark blue text 

background 
 Register tree knots can be expanded 
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KEIL µVision – Debug (6) 

 Variable Windows 
 Watch Windows 

• Up to 2 Watch windows are sharing their tabs with e.g. Memory and 
Local views 

• Updated during runtime 
• Any changes are highlighted in dark blue text backround color 
• Displayed values can be changed by user during break 

 
 
 

 Local View 
• The local view shares the tab with e.g. Memory and Watch windows 
• Any changes are highlighted in dark blue text backround color 
• Displayed values can be changed by user during break 
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KEIL µVision – Trace (ULINK ME) 

 Trace via ITM 
 Simple Trace views via Instrumentation Trace Macro is supported by 

µLINK ME 
• Records 
• Exceptions 
• Counters 
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KEIL µVision –  
Trace (ULINK Pro) (1) 
 Trace via ETM 

 Check settings in menu: 
Flash→Configure Flash Tools... Tab:Debug 
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enables ETM pins 
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KEIL µVision –  
Trace (ULINK Pro) (2) 
 Instruction Trace 

 Real Time Trace recording 
 Output can be filtered by several ETM and ITM events 
 Trace buffer is held in PC memory and transfered to µVision on break 
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KEIL µVision – Simulator 

 Simulator 
 The Core Simulator can be selected by the menu: 

Flash→Configure Flash Tools... and then choosing Use Simulator 
 Look & feel is like using ULINK debugger 
 Controlable also with *.ini files 
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Support 

China:   fsla.mcu-kit.FSS@sg.fujitsu.com 
 

Europe / EMEA:  mcu_ticket.FSEU@de.fujitsu.com 
 

Japan:  
https://jp.fujitsu.com/cgi-bin/fjid/formoutput_cs.cgi?FMT=/contact/csform/csque00901/form0010/1 
 

USA:  FSA_ARMMCU_TOOL@us.fujitsu.com 
 

Other:  mcu_ticket.FSEU@de.fujitsu.com 
 
 

 Visit our global FM3 microcontroller website 
http://www.fujitsu.com/global/services/microelectronics/product/micom/roadmap/industrial/fm3/ 
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Further Steps 

 In order to learn more about Fujitsu’s microcontrollers 
 Visit our microcontroller website (Global) 

• http://www.fujitsu.com/global/services/microelectronics/product/micom/roadmap/industrial/fm3/ 

 Visit our microcontroller website (Europe) 
• http://mcu.emea.fujitsu.com   (General Microcontrollers Website) 
• http://emea.fujitsu.com/fm3    (FM3 Website) 
• http://mcu.emea.fujitsu.com/mcu_product/detail/MB9AF312KPMC.htm             (MCU Website) 
• http://mcu.emea.fujitsu.com/mcu_tool/detail/SK-FM3-48PMC-USBSTICK.htm (EVB Website) 

 See our application notes (Europe) 
• http://mcu.emea.fujitsu.com/mcu_product/mcu_all_appnotes.htm 

 See our software examples (Europe) 
• http://mcu.emea.fujitsu.com/mcu_product/mcu_all_software.htm 

 

 Contact your local distributor … 
 for individual support 
 to register for our monthly FM3 seminar   
 to order the latest ‘Fujitsu Micros DVD’ containing all information regarding 

Fujitsu’s 8-bit, 16-bit, and 32-bit microcontrollers 
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Fujitsu Semiconductor Europe 

http://www.fujitsu.com/emea/contact/microelectronics/salesoffices/ 
 

Germany (Headquarters)  
63225 Langen   Tel: +49 (0) 61 03 69 00   

 France  
91300 Massy    Tel: +33 (0) 1 64 47 97 00 

 Italy  
20080 Milano   Tel: +39 02 90 45 02 1 

 United Kingdom   
Maidenhead   Tel: +44 (0) 1628 50 46 00 

 Hungary  
1143 Budapest   Tel: +36 1 471 21 29 

 Turkey  
34180 Istanbul   Tel: +90 212 557 18 81 
 

 World Wide Web 
 http://emea.fujitsu.com/microelectronics 
 http://mcu.emea.fujitsu.com 
 Contact:  mcu_ticket.FSEU@de.fujitsu.com 
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Contacts – Distribution - Europe 

 European distributors 
 

 EBV Elektronik                          www.ebv.com 
 Farnell                                        www.farnell.com 
 Glyn                                            www.glyn.de , www.glyn.ch 
 Melchioni Electronica               www.melchioni.it 
 MSC                www.msc-ge.com 
 Rutronik Elektronische             www.rutronik.com 
    Bauelemente 
 SpecialIND                www.specialind.it 
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EG-Konformitätserklärung / 
EC declaration of conformity 

 
 
 
 
 
 
Hiermit erklären wir, Fujitsu Semiconductor Europe GmbH, Pittlerstrasse 47, 63225 Langen, Germany 
dass dieses Board aufgrund seiner Konzipierung und Bauart sowie in den von uns in Verkehr gebrachten  
Ausführung(en) den grundlegenden Anforderungen der EU-Richtlinie 2004/108/EC "Elektromagnetische Verträglichkeit"  
entspricht. Durch eine Veränderung des Boards (Hard- und/ oder Software) verliert diese Erklärung ihre Gültigkeit! 
 
We, Fujitsu Semiconductor Europe GmbH, Pittlerstrasse 47, 63225 Langen, Germany  
hereby declare that the design, construction and description circulated by us of this board 
complies with the appropriate basic safety and health requirements according to the EU Guideline 2004/108/EC entitled  
’Electro-Magnetic Compatibility’. Any changes to the equipment (hardware and/ or software) will render this declaration  
invalid! 
 
 

 

Note: 
All data and power supply lines connected to this starter kit should be kept as short as possible, with a maximum  
allowable length of 3m. Shielded cables should be used for data lines. As a rule of thumb, the cable length used when  
connecting external circuitry to the MCU pin header connectors for example should be less than 20cm. Longer cables 
may affect EMC performance and cause radio interference. 
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Recycling (Europe) 

 Gültig für EU-Länder: 
 Gemäß der Europäischen WEEE-Richtlinie und deren Umsetzung  

in landesspezifische Gesetze nehmen wir dieses Gerät wieder zurück. 
 Zur Entsorgung schicken Sie das Gerät bitte an die folgende Adresse: 
  

 Valid for European Union Countries: 
 According to the European WEEE-Directive and its implementation  

into national laws we take this device back. 
 For disposal please send the device to the following address: 

Fujitsu Semiconductor Europe GmbH 
Warehouse/Disposal  

Monzastraße 4a 
D-63225 Langen 

 
 This board is compliant with China RoHS 
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