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 ET-ICDX V1.0  

 

 ET-ICDX V1.0  เปนเคร่ืองมือที่ใชในการโปรแกรมและดีบักไมโครคอนโทรลเลอร PIC ของ

บริษัท microchip โดยการใชงานจะตองใชงานกับโปรแกรม MPLAB ซึ่งสามารถดาวนโหลดมาใชได

ฟรีที่ www.microchip.com  ซึ่ง ณ ปจจุบันที่เขียนเอกสารนี้คือเวอรชั่น 8.10 โดยเบอรของ PIC ที่ ET-

ICDX V1.0 สามารถโปรแกรมและดีบักไดมีดังนี้ซึ่งสามารถเพิ่มข้ึนไดในอนาคตในกรณีที่มี MPLAP 

เวอรชั่นใหม 

 
Device Support List 

  Debugger - Full Support 

dsPIC30F2010 dsPIC30F4011 dsPIC30F6011A 

dsPIC30F2011 dsPIC30F4012 dsPIC30F6012 

dsPIC30F2012 dsPIC30F4013 dsPIC30F6012A 

dsPIC30F2020 dsPIC30F5011 dsPIC30F6013 

dsPIC30F2023 dsPIC30F5013 dsPIC30F6013A 

dsPIC30F3010 dsPIC30F5015 dsPIC30F6014 

dsPIC30F3011 dsPIC30F5016 dsPIC30F6014A 

dsPIC30F3012 dsPIC30F6010 dsPIC30F6015 

dsPIC30F3013 dsPIC30F6010A   

dsPIC30F3014 dsPIC30F6011   

      

dsPIC33FJ128GP202 dsPIC33FJ12GP201 dsPIC33FJ64GP202 

dsPIC33FJ128GP204 dsPIC33FJ12GP202 dsPIC33FJ64GP204 

dsPIC33FJ128GP206 dsPIC33FJ12MC201 dsPIC33FJ64GP206 

dsPIC33FJ128GP306 dsPIC33FJ12MC202 dsPIC33FJ64GP306 

dsPIC33FJ128GP310 dsPIC33FJ16GP304 dsPIC33FJ64GP310 

dsPIC33FJ128GP706 dsPIC33FJ16MC304 dsPIC33FJ64GP706 

dsPIC33FJ128GP708 dsPIC33FJ256GP506 dsPIC33FJ64GP708 
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dsPIC33FJ128GP710 dsPIC33FJ256GP510 dsPIC33FJ64GP710 

dsPIC33FJ128GP802 dsPIC33FJ256GP710 dsPIC33FJ64GP802 

dsPIC33FJ128GP804 dsPIC33FJ256MC510 dsPIC33FJ64GP804 

dsPIC33FJ128MC202 dsPIC33FJ256MC710 dsPIC33FJ64MC202 

dsPIC33FJ128MC204 dsPIC33FJ32GP202 dsPIC33FJ64MC204 

dsPIC33FJ128MC506 dsPIC33FJ32GP204 dsPIC33FJ64MC506 

dsPIC33FJ128MC510 dsPIC33FJ32GP302 dsPIC33FJ64MC508 

dsPIC33FJ128MC706 dsPIC33FJ32GP304 dsPIC33FJ64MC510 

dsPIC33FJ128MC708 dsPIC33FJ32MC202 dsPIC33FJ64MC706 

dsPIC33FJ128MC710 dsPIC33FJ32MC204 dsPIC33FJ64MC710 

dsPIC33FJ128MC802 dsPIC33FJ32MC302 dsPIC33FJ64MC802 

dsPIC33FJ128MC804 dsPIC33FJ32MC304 dsPIC33FJ64MC804 

      

MCV08A     

      

PIC10F200 PIC10F204 PIC10F220 

PIC10F202 PIC10F206 PIC10F222 

      

PIC12F508 PIC12F615 PIC12F683 

PIC12F509 PIC12F629 PIC12HV609 

PIC12F510 PIC12F635 PIC12HV615 

PIC12F609 PIC12F675   

      

PIC16F505 PIC16F690 PIC16F876A 

PIC16F506 PIC16F716 PIC16F877 

PIC16F610 PIC16F737 PIC16F877A 

PIC16F616 PIC16F747 PIC16F88 
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PIC16F627A PIC16F767 PIC16F882 

PIC16F628A PIC16F777 PIC16F883 

PIC16F630 PIC16F785 PIC16F884 

PIC16F631 PIC16F818 PIC16F886 

PIC16F636 PIC16F819 PIC16F887 

PIC16F639 PIC16F87 PIC16F913 

PIC16F648A PIC16F870 PIC16F914 

PIC16F676 PIC16F871 PIC16F916 

PIC16F677 PIC16F872 PIC16F917 

PIC16F684 PIC16F873 PIC16F946 

PIC16F685 PIC16F873A PIC16HV616 

PIC16F687 PIC16F874 PIC16HV785 

PIC16F688 PIC16F874A   

PIC16F689 PIC16F876   

      

PIC18C601 PIC18F4458 PIC18F66J65 

PIC18C801 PIC18F448 PIC18F6720 

PIC18F1220 PIC18F4480 PIC18F6722 

PIC18F1230 PIC18F44J10 PIC18F6723 

PIC18F1320 PIC18F44K20 PIC18F67J10 

PIC18F1330 PIC18F4510 PIC18F67J11 

PIC18F2220 PIC18F4515 PIC18F67J50 

PIC18F2221 PIC18F452 PIC18F67J60 

PIC18F2320 PIC18F4520 PIC18F8310 

PIC18F2321 PIC18F4523 PIC18F8390 

PIC18F2331 PIC18F4525 PIC18F8393 

PIC18F2410 PIC18F4539 PIC18F83J11 
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PIC18F242 PIC18F4550 PIC18F83J90 

PIC18F2420 PIC18F4553 PIC18F8410 

PIC18F2423 PIC18F458 PIC18F8490 

PIC18F2431 PIC18F4580 PIC18F8493 

PIC18F2439 PIC18F4585 PIC18F84J11 

PIC18F2450 PIC18F45J10 PIC18F84J90 

PIC18F2455 PIC18F45K20 PIC18F8520 

PIC18F2458 PIC18F4610 PIC18F8525 

PIC18F248 PIC18F4620 PIC18F8527 

PIC18F2480 PIC18F4680 PIC18F8585 

PIC18F24J10 PIC18F4682 PIC18F85J10 

PIC18F24K20 PIC18F4685 PIC18F85J11 

PIC18F2510 PIC18F6310 PIC18F85J15 

PIC18F2515 PIC18F6390 PIC18F85J50 

PIC18F252 PIC18F6393 PIC18F85J90 

PIC18F2520 PIC18F63J11 PIC18F8620 

PIC18F2523 PIC18F63J90 PIC18F8621 

PIC18F2525 PIC18F6410 PIC18F8622 

PIC18F2539 PIC18F6490 PIC18F8627 

PIC18F2550 PIC18F6493 PIC18F8628 

PIC18F2553 PIC18F64J11 PIC18F8680 

PIC18F258 PIC18F64J90 PIC18F86J10 

PIC18F2580 PIC18F6520 PIC18F86J11 

PIC18F2585 PIC18F6525 PIC18F86J15 

PIC18F25J10 PIC18F6527 PIC18F86J16 

PIC18F25K20 PIC18F6585 PIC18F86J50 

PIC18F2610 PIC18F65J10 PIC18F86J55 
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PIC18F2620 PIC18F65J11 PIC18F86J60 

PIC18F2680 PIC18F65J15 PIC18F86J65 

PIC18F2682 PIC18F65J50 PIC18F8720 

PIC18F2685 PIC18F65J90 PIC18F8722 

PIC18F4220 PIC18F6620 PIC18F8723 

PIC18F4221 PIC18F6621 PIC18F87J10 

PIC18F4320 PIC18F6622 PIC18F87J11 

PIC18F4321 PIC18F6627 PIC18F87J50 

PIC18F4331 PIC18F6628 PIC18F87J60 

PIC18F4410 PIC18F6680 PIC18F96J60 

PIC18F442 PIC18F66J10 PIC18F96J65 

PIC18F4420 PIC18F66J11 PIC18F97J60 

PIC18F4423 PIC18F66J15 PIC18LF24J10 

PIC18F4431 PIC18F66J16 PIC18LF25J10 

PIC18F4439 PIC18F66J50 PIC18LF44J10 

PIC18F4450 PIC18F66J55 PIC18LF45J10 

PIC18F4455 PIC18F66J60   

      

PIC24FJ128GA006 PIC24FJ192GB106 PIC24FJ48GA004 

PIC24FJ128GA008 PIC24FJ192GB108 PIC24FJ64GA002 

PIC24FJ128GA010 PIC24FJ192GB110 PIC24FJ64GA004 

PIC24FJ128GA106 PIC24FJ256GA106 PIC24FJ64GA006 

PIC24FJ128GA108 PIC24FJ256GA108 PIC24FJ64GA008 

PIC24FJ128GA110 PIC24FJ256GA110 PIC24FJ64GA010 

PIC24FJ128GB106 PIC24FJ256GB106 PIC24FJ64GB106 

PIC24FJ128GB108 PIC24FJ256GB108 PIC24FJ64GB108 

PIC24FJ128GB110 PIC24FJ256GB110 PIC24FJ64GB110 
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PIC24FJ16GA002 PIC24FJ32GA002 PIC24FJ96GA006 

PIC24FJ16GA004 PIC24FJ32GA004 PIC24FJ96GA008 

PIC24FJ192GA108 PIC24FJ48GA002 PIC24FJ96GA010 

      

PIC24HJ128GP202 PIC24HJ12GP201 PIC24HJ64GP202 

PIC24HJ128GP204 PIC24HJ12GP202 PIC24HJ64GP204 

PIC24HJ128GP206 PIC24HJ16GP304 PIC24HJ64GP206 

PIC24HJ128GP210 PIC24HJ256GP206 PIC24HJ64GP210 

PIC24HJ128GP306 PIC24HJ256GP210 PIC24HJ64GP502 

PIC24HJ128GP310 PIC24HJ256GP610 PIC24HJ64GP504 

PIC24HJ128GP502 PIC24HJ32GP202 PIC24HJ64GP506 

PIC24HJ128GP504 PIC24HJ32GP204 PIC24HJ64GP510 

PIC24HJ128GP506 PIC24HJ32GP302   

PIC24HJ128GP510 PIC24HJ32GP304   

Debugger - Beta Support 

dsPIC30F1010     

      

dsPIC33FJ06GS202     

dsPIC33FJ16GS502     

dsPIC33FJ16GS504     

      

MCV14A     

      

PIC12F519     

      

PIC16F526     

PIC16F726     
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PIC16F727     

PIC16HV610     

      

PIC18F13K50     

PIC18F26K20     

PIC18F46K20     

      

PIC24FJ192GA106     

PIC24FJ192GA110     

      

PIC32MX320F032H PIC32MX340F256H PIC32MX440F256H 

PIC32MX320F064H PIC32MX360F256L PIC32MX460F256L 

PIC32MX320F128H PIC32MX360F512L PIC32MX460F512L 

PIC32MX320F128L PIC32MX440F128L   

Programmer - Full Support 

dsPIC30F1010 dsPIC30F3014 dsPIC30F6011 

dsPIC30F2010 dsPIC30F4011 dsPIC30F6011A 

dsPIC30F2011 dsPIC30F4012 dsPIC30F6012 

dsPIC30F2012 dsPIC30F4013 dsPIC30F6012A 

dsPIC30F2020 dsPIC30F5011 dsPIC30F6013 

dsPIC30F2023 dsPIC30F5013 dsPIC30F6013A 

dsPIC30F3010 dsPIC30F5015 dsPIC30F6014 

dsPIC30F3011 dsPIC30F5016 dsPIC30F6014A 

dsPIC30F3012 dsPIC30F6010 dsPIC30F6015 

dsPIC30F3013 dsPIC30F6010A   

      

dsPIC33FJ128GP202 dsPIC33FJ12GP201 dsPIC33FJ64GP202 
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dsPIC33FJ128GP204 dsPIC33FJ12GP202 dsPIC33FJ64GP204 

dsPIC33FJ128GP206 dsPIC33FJ12MC201 dsPIC33FJ64GP206 

dsPIC33FJ128GP306 dsPIC33FJ12MC202 dsPIC33FJ64GP306 

dsPIC33FJ128GP310 dsPIC33FJ16GP304 dsPIC33FJ64GP310 

dsPIC33FJ128GP706 dsPIC33FJ16MC304 dsPIC33FJ64GP706 

dsPIC33FJ128GP708 dsPIC33FJ256GP506 dsPIC33FJ64GP708 

dsPIC33FJ128GP710 dsPIC33FJ256GP510 dsPIC33FJ64GP710 

dsPIC33FJ128GP802 dsPIC33FJ256GP710 dsPIC33FJ64GP802 

dsPIC33FJ128GP804 dsPIC33FJ256MC510 dsPIC33FJ64GP804 

dsPIC33FJ128MC202 dsPIC33FJ256MC710 dsPIC33FJ64MC202 

dsPIC33FJ128MC204 dsPIC33FJ32GP202 dsPIC33FJ64MC204 

dsPIC33FJ128MC506 dsPIC33FJ32GP204 dsPIC33FJ64MC506 

dsPIC33FJ128MC510 dsPIC33FJ32GP302 dsPIC33FJ64MC508 

dsPIC33FJ128MC706 dsPIC33FJ32GP304 dsPIC33FJ64MC510 

dsPIC33FJ128MC708 dsPIC33FJ32MC202 dsPIC33FJ64MC706 

dsPIC33FJ128MC710 dsPIC33FJ32MC204 dsPIC33FJ64MC710 

dsPIC33FJ128MC802 dsPIC33FJ32MC302 dsPIC33FJ64MC802 

dsPIC33FJ128MC804 dsPIC33FJ32MC304 dsPIC33FJ64MC804 

      

MCV08A     

MCV14A     

MCV18A     

MCV28A     

      

PIC10F200 PIC10F204 PIC10F220 

PIC10F202 PIC10F206 PIC10F222 
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PIC12F508 PIC12F615 PIC12HV609 

PIC12F509 PIC12F629 PIC12HV615 

PIC12F510 PIC12F635 rfPIC12F675K 

PIC12F519 PIC12F675   

PIC12F609 PIC12F683   

      

PIC16F505 PIC16F689 PIC16F873A 

PIC16F506 PIC16F690 PIC16F874 

PIC16F526 PIC16F716 PIC16F874A 

PIC16F54 PIC16F72 PIC16F876 

PIC16F57 PIC16F73 PIC16F876A 

PIC16F59 PIC16F737 PIC16F877 

PIC16F610 PIC16F74 PIC16F877A 

PIC16F616 PIC16F747 PIC16F88 

PIC16F627 PIC16F76 PIC16F882 

PIC16F627A PIC16F767 PIC16F883 

PIC16F628 PIC16F77 PIC16F884 

PIC16F628A PIC16F777 PIC16F886 

PIC16F630 PIC16F785 PIC16F887 

PIC16F631 PIC16F818 PIC16F913 

PIC16F636 PIC16F819 PIC16F914 

PIC16F639 PIC16F83 PIC16F916 

PIC16F648A PIC16F84 PIC16F917 

PIC16F676 PIC16F84A PIC16F946 

PIC16F677 PIC16F87 PIC16HV610 

PIC16F684 PIC16F870 PIC16HV616 

PIC16F685 PIC16F871 PIC16HV785 
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PIC16F687 PIC16F872   

PIC16F688 PIC16F873   

      

PIC18C601 PIC18F4458 PIC18F6720 

PIC18C801 PIC18F448 PIC18F6722 

PIC18F1220 PIC18F4480 PIC18F6723 

PIC18F1230 PIC18F44J10 PIC18F67J10 

PIC18F1320 PIC18F44K20 PIC18F67J11 

PIC18F1330 PIC18F4510 PIC18F67J50 

PIC18F2220 PIC18F4515 PIC18F67J60 

PIC18F2221 PIC18F452 PIC18F8310 

PIC18F2320 PIC18F4520 PIC18F8390 

PIC18F2321 PIC18F4523 PIC18F8393 

PIC18F2331 PIC18F4525 PIC18F83J11 

PIC18F2410 PIC18F4539 PIC18F83J90 

PIC18F242 PIC18F4550 PIC18F8410 

PIC18F2420 PIC18F4553 PIC18F8490 

PIC18F2423 PIC18F458 PIC18F8493 

PIC18F2431 PIC18F4580 PIC18F84J11 

PIC18F2439 PIC18F4585 PIC18F84J90 

PIC18F2450 PIC18F45J10 PIC18F8520 

PIC18F2455 PIC18F45K20 PIC18F8525 

PIC18F2458 PIC18F4610 PIC18F8527 

PIC18F248 PIC18F4620 PIC18F8585 

PIC18F2480 PIC18F4680 PIC18F85J10 

PIC18F24J10 PIC18F4685 PIC18F85J11 

PIC18F24K20 PIC18F6310 PIC18F85J15 
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PIC18F2510 PIC18F6390 PIC18F85J50 

PIC18F2515 PIC18F6393 PIC18F85J90 

PIC18F252 PIC18F63J11 PIC18F8620 

PIC18F2520 PIC18F63J90 PIC18F8621 

PIC18F2523 PIC18F6410 PIC18F8622 

PIC18F2525 PIC18F6490 PIC18F8627 

PIC18F2539 PIC18F6493 PIC18F8628 

PIC18F2550 PIC18F64J11 PIC18F8680 

PIC18F2553 PIC18F64J90 PIC18F86J10 

PIC18F258 PIC18F6520 PIC18F86J11 

PIC18F2580 PIC18F6525 PIC18F86J15 

PIC18F2585 PIC18F6527 PIC18F86J16 

PIC18F25J10 PIC18F6585 PIC18F86J50 

PIC18F25K20 PIC18F65J10 PIC18F86J55 

PIC18F2610 PIC18F65J11 PIC18F86J60 

PIC18F2620 PIC18F65J15 PIC18F86J65 

PIC18F2680 PIC18F65J50 PIC18F8720 

PIC18F2682 PIC18F65J90 PIC18F8722 

PIC18F2685 PIC18F6620 PIC18F8723 

PIC18F4220 PIC18F6621 PIC18F87J10 

PIC18F4221 PIC18F6622 PIC18F87J11 

PIC18F4320 PIC18F6627 PIC18F87J50 

PIC18F4321 PIC18F6628 PIC18F87J60 

PIC18F4331 PIC18F6680 PIC18F96J60 

PIC18F4410 PIC18F66J10 PIC18F96J65 

PIC18F442 PIC18F66J11 PIC18F97J60 

PIC18F4420 PIC18F66J15 PIC18LF24J10 
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PIC18F4423 PIC18F66J16 PIC18LF25J10 

PIC18F4431 PIC18F66J50 PIC18LF44J10 

PIC18F4439 PIC18F66J55 PIC18LF45J10 

PIC18F4450 PIC18F66J60   

PIC18F4455 PIC18F66J65   

      

PIC24FJ128GA006 PIC24FJ192GB106 PIC24FJ48GA004 

PIC24FJ128GA008 PIC24FJ192GB108 PIC24FJ64GA002 

PIC24FJ128GA010 PIC24FJ192GB110 PIC24FJ64GA004 

PIC24FJ128GA106 PIC24FJ256GA106 PIC24FJ64GA006 

PIC24FJ128GA108 PIC24FJ256GA108 PIC24FJ64GA008 

PIC24FJ128GA110 PIC24FJ256GA110 PIC24FJ64GA010 

PIC24FJ128GB106 PIC24FJ256GB106 PIC24FJ64GB106 

PIC24FJ128GB108 PIC24FJ256GB108 PIC24FJ64GB108 

PIC24FJ128GB110 PIC24FJ256GB110 PIC24FJ64GB110 

PIC24FJ16GA002 PIC24FJ32GA002 PIC24FJ96GA006 

PIC24FJ16GA004 PIC24FJ32GA004 PIC24FJ96GA008 

PIC24FJ192GA108 PIC24FJ48GA002 PIC24FJ96GA010 

      

PIC24HJ128GP202 PIC24HJ12GP201 PIC24HJ64GP202 

PIC24HJ128GP204 PIC24HJ12GP202 PIC24HJ64GP204 

PIC24HJ128GP206 PIC24HJ16GP304 PIC24HJ64GP206 

PIC24HJ128GP210 PIC24HJ256GP206 PIC24HJ64GP210 

PIC24HJ128GP306 PIC24HJ256GP210 PIC24HJ64GP502 

PIC24HJ128GP310 PIC24HJ256GP610 PIC24HJ64GP504 

PIC24HJ128GP502 PIC24HJ32GP202 PIC24HJ64GP506 

PIC24HJ128GP504 PIC24HJ32GP204 PIC24HJ64GP510 
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PIC24HJ128GP506 PIC24HJ32GP302   

PIC24HJ128GP510 PIC24HJ32GP304   

Programmer - Beta Support 

dsPIC33FJ06GS202     

dsPIC33FJ16GS502     

dsPIC33FJ16GS504     

      

rfPIC12F675F     

rfPIC12F675H     

      

PIC16F726     

PIC16F727     

      

PIC18F14K50     

PIC18F26K20     

PIC18F4682     

PIC18F46K20     

      

PIC24FJ192GA106     

PIC24FJ192GA110     

      

PIC32MX320F032H PIC32MX340F256H PIC32MX440F256H 

PIC32MX320F064H PIC32MX360F256L PIC32MX460F256L 

PIC32MX320F128H PIC32MX360F512L PIC32MX460F512L 

PIC32MX320F128L PIC32MX440F128L   
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คุณสมบัติของ ET-ICDX V1.0 
- การเช่ือมตอเปน USB (Full Speed 2 M bits/s) 

- สามารถโปรแกรมและดีบักไมโครคอนโทรลเลอร PIC และ dsPIC ได 

- ใชงานรวมกับโปรแกรม MPLAB IDE (ดาวนโหลดฟรี) 

- สามารถอัพเกรดเพิ่มเติมเบอรของไมโครคอนโทรลเลอร ใหมๆ ดวยตนเองผานทาง

คอมพิวเตอร 

- สามารถใชงานรวมกับบอรดเปาหมายที่มีไฟเล้ียงต้ังแต 2.0-6.0 V ได 

- มี LED แสดงผลการทํางาน POWER,BUSY,ERROR 

- สามารถอานและเขียนพื้นที่ในหนวยความจําและสวนของพื้นที่อีอีพรอมได 

- สามารถโปรแกรมคา configuration bits ได 

- ใชแจกแบบโมดูลาร 6 ขา และจัดเรียงขาตามมาตรฐานแจก ICD2 ของ Microchip ทําให

สามารถใชงานกับบอรดของ Microchip หรือบอรดที่แจ็ก ICD2 ไดทันที 

 
1.การติดต้ังโปรแกรม MPLAB IDE 
 

กอนทีจ่ะใชงาน ET-ICDX V1.0 ไดนั้นผูใชจําเปนที่จะตองทาํการติดต้ังโปรแกรม MPLAB IDE

เสียกอนซึ่งสามารถดาวนโหลดไดที่ www.microchip.com หรือใน CD ROM แผนนี ้

1.1 ทําการติดต้ังโปรแกรม MPLAB IDE โดยการดับเบิลคลิกที่ไฟล Install_MPLAB_v810.exe 

1.2 จากนั้นปรากฏหนาตางดังรูปที่ 1-1 จากนัน้คลิกปุม Next เพื่อสูข้ันตอนตอไป 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 1-1 แสดงหนาตางเร่ิมตนการติดต้ังโปรแกรม 



คูมือการใชงาน ET-ICDX V1.0                                                                                 

ETT CO.,LTD -15- www.etteam.com 

 

1.3 จากนั้นจะปรากฏหนาตางเงือ่นไขการใชงานโปรแกรมดังรูปที่ 1-2 ใหคลิกยอมรับและคลิกที่ปุม 

Next 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 1-2 หนาตางเงื่อนไขการใชงานโปรแกรม 

 

1.4 เลือกรูปแบบการติดต้ังโปรแกรมตามตองการในที่นี้จะเลือกแบบ Compleate จากนั้นคลิกปุม 

Next ดังรูปที่ 1-3 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 1-3 แสดงหนาตางเลือกรูปแบบการติดต้ังโปรแกรม 
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1.5  จากนัน้กน็ําการติดต้ังตอไปเร่ือยๆ ซึ่งกเ็หมือนกับการติดต้ังซอพแวรบนวนิโดวทั่วไป  เมื่อการ

ติดต้ังโปรแกรมเสร็จสมบูรณโปรแกรมจะถามวาตองการ Restart คอมพิวเตอรใหมหรือไมใหคลิก  

Yes และคลิกปุม Finish ดังรูปที่ 1-4 เปนอันเสร็จส้ินการติดต้ังโปรแกรม MPLAB IDE 

 

 

 

 

 

   

 

        

 

 

 

รูปที่ 1-4 แสดงหนาตางเมื่อการติดต้ังโปรแกรมเสร็จสมบูรณ 

 

2. การติดต้ังไดรเวอรสําหรับ ET-ICDX V1.0 
 
2.1 เมื่อไดทําการติดต้ังโปรแกรม MPLAB IDE เรียบรอยแลวข้ันตอนตอไปก็เปนการติดต้ังไดรเวอรของ 

ET-ICDX V1.0 ซึ่งสามารถทําไดโดย ทําการเช่ือมตอสาย USB จากคอมพิวเตอรเขากับ ET-ICDX 

V1.0 จากนัน้วนิโดวสจะตรวจสอบพบฮารดแวรใหมดังรูปที่ 2-1 

 

 

 

 

 

 

รูปที่ 2-1 แสดงเมื่อวนิโดวสตรวจพบอารดแวรใหม 
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2.2 จากนั้นจะปรากฏหนาตาง Found New Hardware Wizard ใหเลือกที่ No,not this time และคลิก

ที่ปุม Next ดังรูปที่ 2-2 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-2 แสดงหนาตาง Found New Hardware Wizard 

 

2.3 จากนั้นจะปรากฏหนาตางเพือ่ใหเลือกรูปแบบการติดต้ังไดรเวอรใหเลือก Install from a list or  

Specific location (Advanced) และคลิกที่ปุม Next ดังรูปที่ 2-3 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-3 แสดงหนาตางเพื่อใหเลือกรูปแบบการติดต้ังไดรเวอร 
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2.4 จากนั้นจะปรากฏหนาตางเพื่อใหระบุตําแหนงที่ต้ังของไดรเวอร ใหทาํการคลิกที่ปุม Browse และ

เลือกไปที่ C:\Program Files\Microchip\MPLAB IDE\ICD2\Drivers และคลิกปุม Next ดังรูปที่ 2-4 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-4 แสดงหนาตางเพื่อใหระบุตําแหนงที่ต้ังของไดรเวอร 

 

2.5 จากนั้นวนิโดวจะเร่ิมตนการคนหาไดรเวอรดังรูปที่ 2-5 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-5 แสดงหนาตางคนหาไดรเวอร 
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2.6 เมื่อพบไดรเวอรแลวใหคลิกปุม Next ดังรูปที่ 2-6 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-6 หนาตางแสดงเม่ือพบไดรเวอร 

 

2.7 จากนั้นวนิโดวจะเร่ิมทาํการติดต้ังไดรเวอรดังรูปที่ 2-7 และเมื่อติดต้ังเสร็จเรียบรอยจะปรากฏ

หนาตางดังรูปที่ 2-8 ใหคลกที่ปุม Finish เพื่อเสร็จส้ินการติดต้ังไดรเวอร 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-7 แสดงหนาตางเมื่อวินโดวเร่ิมทาํการติดต้ังไดรเวอร 
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รูปที่ 2-8 หนาตางแสดงเม่ือการติดต้ังไดรเวอรเสร็จสมบูรณ 

 

2.8 ถาการติดต้ังไดรเวอรสมบูรณไมมีขอผิดพลาดใดๆ เมื่อเขาไปดูที่ Device Manager ของวินโดวจะ

พบช่ือของอุปกรณ Microchip Tools ดังรูปที่ 2-9 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 2-9 แสดงหนาตาง Device Manager 
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1 23 4 5 6

ET-ICDX V1.0

3. การตอ ET-ICDX V1.0 เขากับบอรดเปาหมาย 
 

ET-ICDX V1.0 สามารถจะตอกับบอรดเปาหมายที่มีแจก ICD2 หรือ ICSP (ใชรวมกับ สาย 

ICD2 to ICSP) ที่มีการจัดเรียงขาตามมาตรฐาน Microchip ไดทันที ซึ่งตําแหนงและช่ือขาสัญญาณ

แสดงดังรูปที่ 3-1 

 

                                                                                  

 

 

 

 

 

 

รูปที่ 3-1 แสดงตําแหนงและชื่อขาสัญญาณของ ET-ICDX V 1.0 

 

โดยทีห่นาที่ของขาตางๆ มดัีงนี ้

1. MCLR/VPP  เปนขาโปรแกรมแรงดันไฟสูงจะตอกับ RESET หรือขา MCLR ของ MCU 

2. VDD เปนขาไฟเล้ียงของ MCU ซึ่งจะตองตอขานี้กับไฟเล้ียงของบอรดเปาหมาย  (3.3V,5V) 

3. GND เปนขากราวด ซึง่จะตองตอกับกราวดของบอรดเปาหมาย 

4. PGD เปนขา PROGRAM DATA ซึ่งจะตองตอกับขา PGD ของ MCU 

5. PGC เปนขา PROGRAM CLOCK ซึ่งจะตองตอกับขา PGC ของ MCU 

6. NOT USED ขานี้จะเปนขาวางไมไดใชงาน 

 

 

 

 

 

 

 

 

 

ตําแหนงขา ชื่อสัญญาณ 
1 MCLR/VPP 
2 VDD 
3 GND 
4 PGD 
5 PGC 
6 NOT USED 
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รูปที่ 3-2 แสดงการเชื่อมตอ ET-ICDX V1.0 กับบอรด CP-PIC V4 (ICD2) 

 

 

 

 
 

 

 

 

 

 

 

 

 

รูปที่ 3-3 ตัวอยางการใชงานรวมกบับอรด ADAPTER MODULE ของ ETT 
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รูปที่ 3-4 แสดงตัวอยางสาย ICD2 to ICSP 

 
หมายเหตุ   
- เนื่องจาก ET-ICDX V1.0 ไมมีวงจรสวนนาํไฟ 5 V จาก USB ไปเล้ียงบอรดเปาหมายดังนัน้บอรด

เปาหมายตองมีไฟเล้ียงบอรดตางหาก 

- การใชงานตองตอ ET-ICDX V1.0 เขากบัคอมพิวเตอรกอน  ทีจ่ะเปดโปรแกรม MPLAB IDE  มิฉะนั้น

อาจจะทําใหการติดตอส่ือสารระหวางโปรแกรมกับ ET-ICDX V1.0 เกดิปญหาได 

 

4. การโปรแกรมและดีบักดวยภาษาแอสแซมบล ี
  

ในที่จะยกตัวอยางโดยใชบอรด CP-PIC V4(ICD2) ซึ่งใช MCU PIC16F877  กอนการใชงาน

นั้นตองตอบอรดตางๆ เรียบรอยกอนและ เล่ือน SW MODE ของบอรด CP-PIC V4(ICD2) ไปที่

ตําแหนง PROG ซึ่งข้ันตอนการใชงานตาง ๆ มีดังนี ้
 
4.1 หลังจากตอ ET-ICDX V1.0 เขากับคอมพิวเตอรและตอสายตางเขากับบอรดเปาหมายแลวก็ให

เปดโปรแกรม MPLAB IDE โดยการดับเบิลคลิกที่ไอคอนโปรแกรม ดังรูปที่ 4-1  

 

 

 

 

 

รูปที่ 4-1 แสดงไอคอนของโปรแกรม MPLAB IDE 
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4.2 จากนั้นจะปรากฏหนาตางของโปรแกรม MPLAB IDE ดังรูปที่ 4-2 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-2 แสดงหนาตางของโปรแกรม MPLAB IDE 

 

4.3 ทําการสรางโปรเจคใหมโดยเลือกทีเ่มนู Project>New… ดังรูปที ่4-3 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-3 แสดงหนาตางการสรางโปรเจคใหม 

 

 

 



คูมือการใชงาน ET-ICDX V1.0                                                                                 

ETT CO.,LTD -25- www.etteam.com 

 

4.4 จากนั้นจะปรากฏหนาตาง New Project ใหทําการต้ังชื่อ Project  Name และระบุตําแหนงทีจ่ะ

เก็บโปรเจคโดยการคลิกปุม Browse จากนั้นคลิก OK ดังรูปที่ 4-4 

 

 

 

 

 

 

 

รูปที่ 4-4 แสดงหนาตาง New Project 

 

4.5 ทําการเลือกเคร่ืองมือทีจ่ะใชในการเขียนโปรแกรม โดยเลือกที ่Project>Select Language 

Toolsuite… ดังรูปที่ 4-5 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-5 แสดงการเลือกเครื่องมือที่จะใชในการเขียนโปรแกรม 
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4.6 จากนั้นจะปรากฏหนาตาง Select Language Toolsuite ใหเลือก Active Toolsuite เปน 

Microchip MPASM Toolsuite  เพราะวาตัวอยางนี้จะเขียนดวยภาษาแอสแซมบลี จากคลิกปุม OK 

ดังรูปที่ 4-6 

 

 

 

 

 

 

 

 

รูปที่ 4-6 แสดงหนาตาง Select Language Toolsuite 

 

4.7 ทําการเลือกเบอรของ MCU ที่ใชในโดยการเลือกที่เมนู  Configure>Select Device…    

ดังรูปที่ 4-7 

 

 

 

 

 

 

 

รูปที่ 4-7 แสดงการเลือกเบอรของ MCU 

 

4.8  จากนัน้จะปรากฏหนาตาง  Select Device ใหทาํการเลือก Device เปน 16F877 จากนัน้คลิกปุม 

OK ดังรูปที่ 4-8 ขอสังเกตจากหนาตาง Select Device ถา  MCU เบอรไหนสามารถโปรแกรมและดีบัก

ไดดวย MPLAB ICD2 จะมปุีมสีเขียวหนาเคร่ืองมือ จากรูปจะเหน็เปนสีเขียวทัง้ Programmers และ 

Debuggers แสดงวา เบอร 16F877 สามารถทัง้โปรแกรมและดีบักไดนั่นเอง แตถาเปนสีเหลืองแสดง

วาสามารถใชไดแตอาจจะยังไมสมบูรณ สวนถาเปนสีแดงก็ไมสามารถใชไดนั่นเอง 
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รูปที่ 4-8 แสดงหนาตาง  Select Device 

 

4.9 ทําการสรางไฟลที่จะเขียนโคดภาษาแอสแซมบลีโดยไปที่เมนู File>New หรือคลิกที่ไอคอน New 

File ดังรูปที่ 4-9 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-9 แสดงการสรางไฟลใหม 
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4.10 จากนั้นหนาตางวางๆ เพื่อใชสําหรับเขียนโคดดังรูปที่ 4-10 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-10 แสดงหนาตางที่ใชสําหรับเขียนโคด 

 

4.11 ทําการเขียนโคดภาษาแอสแซมบลีดังรูปที่ 4-11 ซึ่งจากตัวอยางจะเปนโปรแกรมไฟกระพริบออก

ที่ PORT RA0 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-11 แสดงการเขียนโคดภาษาแอสแซมบลี 
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4.12 ทําการบันทกึไฟลทีเ่ขียนข้ึนมาโดยไปที่เมนู File>Save หรือคลิกที่ไอคอน Save จากนั้นจะ

ปรากฏหนาตาง Save As ใหต้ังชื่อไฟลเปน blink.asm และเก็บไวที่เดียวกับที่เก็บโปรเจคตอนแรก

จากนั้นคลิกปุม Save ดังรูปที่ 4-12  

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-12 แสดงหนาตาง Save As 

 

4.13 ทําการเพิ่มไฟลภาษาแอสแซมบลีทีเ่ขียนเขาไปในโปรเจคโดยการเลือกที่เมนู Project>Add Files 

to Project ดังรูปที่ 4-13 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-13 แสดงวิธีการเพิม่ไฟลเขาไปในโปรเจค 
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4.14  จากนัน้จะปรากฏหนาตาง Add Files to Project ใหทาํการเลือกที่ไดทาํการบันทกึไวจากข้ันตอน

ที่ผานมาจากนั้นคลิก Open ดังรูปที่ 4-14 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-14 แสดงหนาตาง Add Files to Project 

 

4.15 ทําการคอมไพลโคดที่เขียนข้ึนโดยเลือกที่เมนู Project>Build All หรือคลิกที่ไอคอน Build All ดัง

รูปที่ 4-15 

 

 

 

 

 

 

 

 

รูปที่ 4-15 แสดงวิธีการคอมไพลโคดที่เขียนข้ึน 

 

4.16 ถาโคดทีเ่ขียนข้ึนถูกตองตามหลักไวยกรณ (Syntex) จะปรากฏขอความดังรูปที่ 4-16  ถาไม

ถูกตอง  ก็จะมีขอความแจงเตือนขอผิดพลาดข้ึนมาใหทําการแกไขและคอมไพลใหม 
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รูปที่ 4-16 แสดงเมื่อโคดที่เขียนข้ึนถกูตองตามหลักไวยกรณ  

 

4.17 เมื่อทุกอยางเรียบรอยใหทดลองโปรแกรมไฟล “blink.hex” ที่ไดจากการคอมไพลเขาสู MCU โดย

ผูใชจะตองเลือกเคร่ืองที่จะใชในการโปรแกรม  โดยเลือกไปที่เมนู  Programmer>Select 

Programmer>Select Programmer>MPLAB ICD 2 ดังรูปที่ 4-17 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-17 แสดงการเลือกเคร่ืองที่จะใชในการโปรแกรม 
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4.18 จากนั้นจะมีขอความวาเราไมไดต้ังคาให ICD2 ติดตออัตโนมัติเมื่อเร่ิมใชงานดังรูปที่ 4-18 

 

 

 

 

 

 

 

 

รูปที่ 4-18 แสดงขอความใหต้ังคา ICD2 

 

4.19 ทําการต้ังคาของ ICD2 โดยเลือกที่เมนู Programmer>Settings.. ดังรูปที ่4-19 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-19  แสดงการตั้งคาของ ICD2 

 

4.20 จากนั้นจะปรากฏหนาตาง MPLAB ICD2 Settings ใหทาํการเลือก  Automatically connect at 

startup และ Automatically download firmware if needed  ดังรูปที ่4-20 สวน Communication 

เลือกเปน USB ดังรูปที่ 4-21 จากนั้นคลิกปุม OK  
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รูปที่ 4-20 แสดงการต้ังคารูปแบบการติดตอ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-21 แสดงการเลือกพอรตที่ใชติดตอ 
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4.21 จากนั้นคลิกที่ไอคอน Reset and Connect to ICD ดังรูปที ่4-22 เพื่อทาํการเชื่อมตออีกคร้ัง 

 

 

 

 

รูปที่ 4-22 แสดงวิธีการเชื่อมตอกับ ICD2 

 

4.22 รอสักครูโปรแกรมจะทาํการโหลดขอมูลตางๆ ของ MCU ที่ใชเขาสู ET-ICDX V1.0  เมื่อทุกอยาง

เสร็จโปรแกรมจะเจอ  MCU เบอร PIC16F877  ดังรูปที่ 4-23 

 

 

 

 

 

 

 

 

รูปที่ 4-23 แสดงเมื่อ ET-ICDX V1.0 ติดตอกับบอรดเปาหมายสําเร็จ 

 

4.23 ในกรณีที่ทาํการติดตอแลวไมเจอ MCU ดังรูปที่ 4-24 อาจจะมสีาเหตุไดหลายอยางเชนไมมี

ไฟเล้ียงบอรดเปาหมาย,ตอสายผิด หรือไมก็  MCU เสีย ใหทาํการตรวจสอบและแกไข  จากนัน้กท็าํ

การเช่ือมตอใหมอีกคร้ัง 

 

 

 

 

 

 

 

 

รูปที่ 4-24 แสดงเมื่อไมสามารถติดตอกับบอรดเปาหมายได 
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4.24 เมื่อทุกอยางเรียบรอยก็ใหทาํการโปรแกรม hex ไฟลที่ไดจากการคอมไพลเขาสู MCU โดยคลิกที่

ไอคอน Program target device ดังรูปที ่4-25  

 

 

 

 

รูปที่ 4-25 แสดงการโปรแกรม hex ไฟล 

 

4.25 ถาการโปรแกรมไมพบขอผิดพลาดก็จะปรากฏขอความ Programming succeeded ดังรูปที่  

4-26 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-26 แสดงเมื่อการโปรแกรมเสร็จสมบูรณ 

 

4.26 จะเหน็วาตอนนีโ้ปรแกรมที่เขียนไวยงัไมทาํงานใหคลิกที่ปุม Release from Reset ดังรูปที่ 4-27 

จากนั้นจะเหน็วา LED ที่พอรต RA0 จะกระพริบตามโปรแกรมที่เขียนไว 

 

 

 

 

รูปที่ 4-27 แสดงปุม Release from Reset 
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4.27 หลังจากไดทดลองโปรแกรมกันแลวข้ันตอไป  จะทําการทดลองดีบักดูคาตางๆ กัน โดยจะทาํการ

ปดลูบโปรแกรมหนวงเวลาเพื่อใหงายตอการดีบัก  ดังรูปที่ 4-28  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-28 แสดงการปดลูปหนวงเวลา 

 

4.28 จากนั้นใหคอมไพลโปรแกรมที่แกไขใหมโดยคลิกทีปุ่ม Build All ดังรูปที่ 4-29  

 

 

 

รูปที่ 4-29 แสดงการคอมไพลที่แกไข 

 

4.29 ทําการเลือก Debugger เปน MPLAB ICD2  ดังรูปที่ 4-30  

 

 

 

 

 

รูปที่ 4-30 แสดงการเลือก Debugger 
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4.30 จากนั้นจะปรากฏหนาตาง MPLAB ICD2 Warning ข้ึนมาถามวาตองการจะยกเลิก MPLAB 

ICD2 ในโหมด Programmer หรือไม  ใหตอบตกลงโดยคลิกที่ปุม OK ดังรูปที่ 4-31  

 

 

 

 

 

 

 

 

รูปที่ 4-31 แสดงหนาตาง MPLAB ICD2 Warning 

 

4.31 จากนั้นโปรแกรมจะทําการติดตอกับบอรดปลายทางอีกคร้ัง  ดังรูปที่ 4-32  

 

 

 

 

 

 

 

 

รูปที่ 4-32 แสดงเมื่อ ET-ICDX V1.0 ติดตอกับบอรดเปาหมายสําเร็จ 

 

4.32  ทาํการโปรแกรม hex ไฟลที่จะใชในการดีบัก  โดยคลิกที่ Program target device ดังรูปที่ 4-33 

 

 

 

 

รูปที่ 4-33 แสดงการโปรแกรม hex ไฟล 
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4.33 ทําเพิ่มรีจิสเตอรหรือตัวแปรที่ตองการดูคาโดยไปทีเ่มนู View>Watch ดังรูปที่ 4-34 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-34 แสดงการเพิ่มรีจสิเตอรหรือตัวแปร 

 

4.34 จากนั้นจะปรากฎหนาตาง Watch ดังรูปที่ 4-35  ใหทาํการเลือกรีจิสเตอรที่ตองการดูคาจากนั้น

คลิกที่ปุม Add SFR ในที่นีจ้ะเลือก TRISA,ADCON1 และ PORTA 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-35 แสดงหนาตาง Watch 
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4.35 เมื่อไดทําการเพิ่มรีจิสเตอรตางๆ เสร็จเรียบรอยจะไดดังรูปที่ 4-36  

 

 

 

 

 

 

รูปที่ 4-36 แสดงเมื่อไดทําการเพิ่มรีจิสเตอรตางๆ เสร็จเรียบรอย 

 

4.36 เร่ิมตนการดีบักโดยการกดปุม Step Into ดังรูปที่ 4-37 ไปเร่ือยๆ  จะสังเกตเหน็ลูกศรสีเขียวช้ีไป

บรรทัดที่ทาํงานอยูและคารีจสิเตอร  ก็จะเปล่ียนแปลงตามที่เขียนโปรแกรมไวดวย ดังรูปที่ 4-38  

 

 

รูปที่ 4-37 แสดงปุม Step Into 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-38 แสดงคาตางๆ ระหวางการดีบัก 
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4.37 เมื่อไดดีบักผานโปรแกรมบรรทัด BSF PORTA,0 และ BCF PORTA,0 จะเหน็วาคาของ 

PORTA ก็จะเปล่ียนแปลงดังรูปที่ 4-39 และพรอมกนันัน้ LED ที่ตออยูกับ PORT RA0 ก็จะเปล่ียน

สภาวะติดดับตามโปรแกรมพรอมกันไปดวย 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 4-39 แสดงคาตางๆ ระหวางการดีบัก 
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5. การโปรแกรมและดีบักดวยภาษาซี โดยใช CCS รวมกับ MPLAB IDE 
 
 การใชงานในสวนก็ไมไดแตกตางจากภาษาแอสแซมบลีมากนัก จะแตกตางกนัก็คือการเลือก  

Language Toolsuite ในการเขียนโปรแกรมเทานั้น   และผูใชจําเปนจะตองทาํการติดต้ัง คอมไพเลอร 

CCS  ใหเรียบรอยกอนดวย 

 

5.1 ทําการสรางโปรเจคใหม โดยเลือกที่เมนู Project>New ดังรูปที่ 5-1 

 

 

 

 

 

 

 

รูปที่ 5-1 แสดงหนาตาง New Project 

 

5.2  เลือกที่เมนู Project>Select Language Toolsuite… จากนัน้ทําการเลือก Active Toolsuite เปน 

CCS C Compiler ดังรูปที ่5-2 ในกรณีทีผู่ใช ใชคอมไพเลอรตัวอ่ืนเชน C18, C30 หรือ HI-TECH ก็

สามารถเลือกได 

 

 

 

 

 

 

 

 

 

รูปที่ 5-2 แสดงหนาตาง Select Language Toolsuite 
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5.3  ทําการสรางไฟลใหมโดยไปที่เมนู File>New  และเขียนโปรแกรมโคดภาษาซี  ดังรูปที่ 5-3 ซึ่งเปน

โปรแกรมไฟกระพริบทีพ่อรต RA0 เชนเดียวกับโปรแกรมที่แลว  

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 5-3 แสดงการเขียนโปรแกรมภาษาซีที่เขียนข้ึน 

 

5.4 ทําการบันทึกไฟลที่เขียนข้ึนมาโดยไปทีเ่มนู File>Save หรือคลิกที่ไอคอน Save จากนัน้จะปรากฏ

หนาตาง Save As ใหต้ังชื่อไฟลเปน blink.c และเก็บไวที่เดียวกบัทีเ่กบ็โปรเจคตอนแรกจากนัน้คลิกปุม 

Save ดังรูปที่ 5-4 

 

 

 

 

 

 

 

 

 

 

รูปที่ 5-4 แสดงหนาตาง Save AS 
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5.5 ทําการเพิม่ไฟลภาษาซีที่เขียนเขาไปในโปรเจคโดยการเลือกที่เมนู Project>Add Files to Project  

จากนั้นจะปรากฏหนาตาง Add Files to Project ใหทําการเลือกที่ไดทาํการบันทกึไวจากข้ันตอนทีผ่าน

มาจากนัน้คลิก Open ดังรูปที่ 5-5 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 5-5 แสดงการเพิ่มไฟลเขาสูโปรเจค 

 

5.6 ทําการคอมไพลโคดที่เขียนข้ึนโดยเลือกที่เมนู Project>Build All หรือคลิกที่ไอคอน Build All  ถา

โคดที่เขียนข้ึนถูกตองตามหลักไวยกรณ (Syntex) จะปรากฏขอความดังรูปที่ 5-6  ถาไมถูกตอง  กจ็ะมี

ขอความแจงเตือนขอผิดพลาดข้ึนมาใหทาํการแกไขและคอมไพลใหม 

 

 

 

 

 

 

 

 

 

รูปที่ 5-6 แสดงเมื่อโคดที่เขียนข้ึนถกูตองตามหลักไวยกรณ 
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5.7 เมื่อทกุอยางเรียบรอยใหทดลองโปรแกรมไฟล “blink.hex” ที่ไดจากการคอมไพลเขาสู MCU โดย

ผูใชจะตองเลือกเคร่ืองที่จะใชในการโปรแกรม  โดยเลือกไปที่เมนู  Programmer>Select 

Programmer>MPLAB ICD 2  และคลิกที่ไอคอน Program target device ถาทุกอยางไมมีปญหา

เพื่อคลิกที่ไอคอน Release from Reset จะเหน็ LED ทีพ่อรต RA0 กระพริบ 

 

5.8 หลังจากไดทดลองโปรแกรมกันแลวข้ันตอไป  จะทาํการทดลองดีบักดูคาตางๆ กัน โดยจะทําการ

ปดลูบโปรแกรมหนวงเวลาเพื่อใหงายตอการดีบัก ดังรูปที่ 5-7  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 5-7 แสดงการปดลูปหนวงเวลา 

 

5.9 จากนั้นใหคอมไพลโปรแกรมที่แกไขใหมโดยคลิกที่ปุม Build All  ทาํการเลือก Debugger เปน 

MPLAB ICD2  และทําการโปรแกรม hex ไฟลเขาไปใหม หลังจากนัน้ก็ทดลองดีบักซ่ึงวิธกีารก็ไม

แตกตางจากภาษาแอสแซมบลีเลย 
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รูปที่ 5-8 แสดงคาตางๆ ระหวางการดีบักดวยภาษาซี 
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6. การนําเขา hex ไฟลจากภายนอกมาโปรแกรม 
 
 ในกรณีผูใชตองการใช ET-ICDX V1.0 เปนเคร่ืองโปรแกรมโดยนํา hex ไฟลจากโปรแกรมอ่ืนๆ 

ที่ไมรองรับการเช่ือมตอ ICD2 เชน picbasic pro ก็สามารถทําไดโดยการใชวิธี Import เขามาซ่ึงมี

วิธีการดังนี ้ 

 

 6.1  ทําการเชื่อมตอ ET-ICDX V1.0 เขากับคอมพวิเตอรและเช่ือมตอบอรดเปาหมายใหเรียบรอย ซึ่ง

อาจจะเปนบอรด PIC ทั่วไปหรือใชงานรวมกับ ET-PGM PIC TEXT TOOLS  ดังรูปที่ 6-1 ในกรณีที่จะ

เอา MCU ไปใชในบอรดอ่ืน    

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 6-1 แสดงการตอ ET-ICDX V1.0 รวมกับ ET-PGM PIC TEXT TOOLS 

 

6.2 จากนั้นทาํการเปดโปรแกรม MPLAB IDE และไปที่เมนู Configure>Select Device… เพื่อเลือก

เบอรของ MCU ที่จะใชโปรแกรม ดังรูปที ่6-2  

 

 

 

 

 

รูปที่ 6-2 แสดงวิธกีารเลือกเบอรของ MCU 
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6.3 จากนั้นจะปรากฏหนาตาง  Select Device ใหทาํการเลือกเบอรของ MCU ที่ตองการโปรแกรมใน

ที่นี้จะเลือกเปนเบอร 16F877 จากนั้นคลิกปุม OK ดังรูปที่ 6-3 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 6-3 แสดงหนาตาง Select Device 

 

6.4 ทําการเลือกเคร่ืองโปรแกรมเปน MPLAB ICD2 โดยเลือกที่เมน ูProgrammer>Select 

Programmer>MPLAB ICD2 ดังรูปที่ 6-4  

 

 

 

 

 

 

 

 

 

รูปที่ 6-4 แสดงการเลือกเครื่องมีอในการโปรแกรม 
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6.5 ถาบอรดเปาหมายไมมปีญหาจะเจอเบอรของ MCU ที่เลือกใชดังรูปที่ 6-5  

 

 

 

 

 

 

 

 

รูปที่ 6-5 แสดงเมื่อ ET-ICDX V1.0 ติดตอกับบอรดเปาหมายสําเร็จ 

 

6.6 จากนั้นเลือกที่เมนู File>Import ดังรูปที่ 6-6 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 6-6 แสดงวิธกีาร Import ไฟล 

 

6.7 จากนั้นจะปรากฏหนาตาง Open ใหทาํการเลือก hex ไฟลที่ตองการโปรแกรมและคลิกที่ปุม 

Open ดังรูปที ่6-7 
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รูปที่ 6-7 แสดงการเลือก hex ไฟลที่ตองการโปรแกรม 

 

6.8 เมื่อการ Import hex ไฟลไมมีขอผิดพลาดก็จะปรากฏขอความดังรูปที่ 6-8 

 

 

 

 

 

 

 

รูปที่ 6-8 แสดงเมื่อการ Import hex ไฟลเสร็จสมบูรณ 

 

6.9 คลิกที่ไอคอน Program target device เพื่อโปรแกรม hex ไฟล ดังรูปที่ 6-9  

 

 

 

 

รูปที่ 6-9 แสดงวิธกีารโปรแกรม hex ไฟล 
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6.10 ถาการโปรแกรม hex ไฟลไมพบขอผิดพลาดก็ปรากฏขอความดังรูปที่ 6-10  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

รูปที่ 6-10 แสดงเมื่อการโปรแกรม hex ไฟลไมพบขอผิดพลาด 

 

6.11 โดยปกติแลวคา Configuration Bits ของ MCU จะเอามาจาก hex ไฟล  แตในกรณีที่ผูใช

ตองการแกไขคา Configuration Bits เองก็สามารถทําไดโดย เลือกที่เมนู Configure>Configuration 

Bits…  ดังรูปที่ 6.11  

 

 

 

 

 

 

 

 

 

 

รูปที่ 6-11 แสดงวิธีการแกไขคา Configuration Bits 
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6.12 จากนั้นจะปรากฏหนาตาง Configuration Bits ใหเอาเคร่ืองหมายถูกหนาชอง Configuration 

Bits set in code. ออก เพื่อใหผูสามารถกาํหนดคา Configuration Bits เองไดดังรูปที ่6-12 เพื่อทาํการ

แกไขคา Configuration Bits เรียบรอย ก็ใหคลิกที่ไอคอน Program target device เพื่อโปรแกรม hex 

ไฟลตามปกติ 

 

 

 

 

 

 

 

 

 

รูปที่ 6-12 แสดงวิธีการแกไขคา Configuration Bits 




